summaryrefslogtreecommitdiff
path: root/games-arcade/fishsupper/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/fishsupper/files')
-rw-r--r--games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch11
-rw-r--r--games-arcade/fishsupper/files/fishsupper-0.1.6-gcc6.patch49
-rw-r--r--games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch11
3 files changed, 71 insertions, 0 deletions
diff --git a/games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch b/games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch
new file mode 100644
index 000000000000..eae5ca15921a
--- /dev/null
+++ b/games-arcade/fishsupper/files/fishsupper-0.1.6-asneeded.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.am.old 2012-06-24 18:47:58.947143638 +0200
++++ b/src/Makefile.am 2012-06-24 18:51:35.738921904 +0200
+@@ -1,7 +1,7 @@
+ AM_CPPFLAGS = -DPKG_DATA_DIR=\"$(pkgdatadir)\" \
+ @SDL_CFLAGS@ \
+ -Wall
+-AM_LDFLAGS = @SDL_LIBS@
++LDADD = @SDL_LIBS@
+
+ bin_PROGRAMS = fishsupper
+
diff --git a/games-arcade/fishsupper/files/fishsupper-0.1.6-gcc6.patch b/games-arcade/fishsupper/files/fishsupper-0.1.6-gcc6.patch
new file mode 100644
index 000000000000..3ca63cb4a68b
--- /dev/null
+++ b/games-arcade/fishsupper/files/fishsupper-0.1.6-gcc6.patch
@@ -0,0 +1,49 @@
+Bug: https://bugs.gentoo.org/610660
+
+--- a/src/Settings_screen.cpp
++++ b/src/Settings_screen.cpp
+@@ -217,3 +217,7 @@
+
+ // **************************************************
+
++const float FS::Settings_screen::bold = 1.0;
++const float FS::Settings_screen::faded = 0.2;
++
++// **************************************************
+--- a/src/Settings_screen.h
++++ b/src/Settings_screen.h
+@@ -71,8 +71,8 @@
+ static const int tick1_x = 252;
+ static const int tick_y_offset = 33;
+ static const int sprite_texture_start = FS_gfx::JOYSTICK;
+- static const float bold = 1.0;
+- static const float faded = 0.2;
++ static const float bold;
++ static const float faded;
+
+ Settings* settings_ptr;
+ int current_option;
+--- a/src/Star_particle_system.cpp
++++ b/src/Star_particle_system.cpp
+@@ -137,6 +137,10 @@
+ } // FS::Star_particle_system::launch_new_star
+
+ // **************************************************
++
++const float FS::Star_particle_system::lifespan = 1500.0;
++
++// **************************************************
+ // **************************************************
+ // **************************************************
+ // **************************************************
+--- a/src/Star_particle_system.h
++++ b/src/Star_particle_system.h
+@@ -77,7 +77,7 @@
+ static const int STAR_WIDTH = 30;
+ static const int STAR_HEIGHT = 30;
+ // This is a float so that we get floating-point division in update.
+- static const float lifespan = 1500.0; // in ms
++ static const float lifespan; // in ms
+
+ // A particle is basically a lightweight sprite.
+ // Unlike a usual sprite, we don't need to worry about
diff --git a/games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch b/games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch
new file mode 100644
index 000000000000..2be91b65a16d
--- /dev/null
+++ b/games-arcade/fishsupper/files/fishsupper-0.1.6-ovflfix.patch
@@ -0,0 +1,11 @@
+--- a/src/main.cpp.old 2012-06-24 18:35:27.661894094 +0200
++++ b/src/main.cpp 2012-06-24 18:35:41.041954632 +0200
+@@ -293,7 +293,7 @@
+
+ if (!ok)
+ {
+- fs_dir = new char[ strlen(".") ];
++ fs_dir = new char[ strlen(".") + 1];
+ strcpy(fs_dir, ".");
+ } // if ... else
+