summaryrefslogtreecommitdiff
path: root/games-arcade/methane/methane-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/methane/methane-1.5.1.ebuild')
-rw-r--r--games-arcade/methane/methane-1.5.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-arcade/methane/methane-1.5.1.ebuild b/games-arcade/methane/methane-1.5.1.ebuild
new file mode 100644
index 000000000000..5eb599ba6769
--- /dev/null
+++ b/games-arcade/methane/methane-1.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils flag-o-matic games
+
+DESCRIPTION="Port from an old amiga game"
+HOMEPAGE="http://methane.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-games/clanlib:2.3[opengl,mikmod]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}:" \
+ sources/target.cpp || die
+
+ # fix weird parallel make issue wrt #450422
+ mkdir build || die
+ append-cxxflags -Wno-narrowing # build with gcc5 (bug #573788)
+}
+
+src_install() {
+ dogamesbin methane
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins resources/*
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}"/methanescores
+ fperms g+w "${GAMES_STATEDIR}"/methanescores
+ newicon docs/puff.gif ${PN}.gif
+ make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
+ dodoc authors.txt history.txt readme.txt
+ dohtml docs/*
+ prepgamesdirs
+}