summaryrefslogtreecommitdiff
path: root/games-arcade/solarwolf/solarwolf-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/solarwolf/solarwolf-1.5.ebuild')
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/solarwolf/solarwolf-1.5.ebuild b/games-arcade/solarwolf/solarwolf-1.5.ebuild
new file mode 100644
index 000000000000..05453edbe16f
--- /dev/null
+++ b/games-arcade/solarwolf/solarwolf-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="action/arcade recreation of SolarFox"
+HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
+SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.5.6
+ media-libs/sdl-mixer[mod,vorbis]"
+
+src_prepare() {
+ find . -name .xvpics -print0 | xargs -0 rm -fr
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r code data *py
+ games_make_wrapper ${PN} "python2 ./solarwolf.py" "$(games_get_libdir)"/${PN}
+ doicon dist/${PN}.png
+ make_desktop_entry ${PN} SolarWolf
+ dodoc readme.txt
+ doman dist/${PN}.6.gz
+ prepgamesdirs
+}