summaryrefslogtreecommitdiff
path: root/games-emulation/dgen-sdl/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dgen-sdl/files')
-rw-r--r--games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch10
-rw-r--r--games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch20
2 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch
new file mode 100644
index 000000000000..e04efcc01f38
--- /dev/null
+++ b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,6 +25,7 @@
+ AC_PROG_CXXCPP
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
++AM_PROG_AR
+ AC_PROG_RANLIB
+
+ dnl Set the value of make, if make doesn't already.
diff --git a/games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch
new file mode 100644
index 000000000000..55810b004f2c
--- /dev/null
+++ b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch
@@ -0,0 +1,20 @@
+--- a/main.cpp
++++ b/main.cpp
+@@ -82,7 +82,7 @@
+ static void help()
+ {
+ printf(
+- "DGen/SDL v"VER"\n"
++ "DGen/SDL v" VER "\n"
+ "Usage: dgen [options] [romname [...]]\n\n"
+ "Where options are:\n"
+ " -v Print version number and exit.\n"
+@@ -256,7 +256,7 @@
+ {
+ case 'v':
+ // Show version and exit
+- printf("DGen/SDL version "VER"\n");
++ printf("DGen/SDL version " VER "\n");
+ return 0;
+ case 'r':
+ // Parse another RC file or stdin