summaryrefslogtreecommitdiff
path: root/games-emulation/hatari
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/Manifest3
-rw-r--r--games-emulation/hatari/hatari-2.1.0.ebuild76
-rw-r--r--games-emulation/hatari/metadata.xml11
3 files changed, 90 insertions, 0 deletions
diff --git a/games-emulation/hatari/Manifest b/games-emulation/hatari/Manifest
new file mode 100644
index 000000000000..b004751ca1f6
--- /dev/null
+++ b/games-emulation/hatari/Manifest
@@ -0,0 +1,3 @@
+DIST hatari-2.1.0.tar.bz2 4072778 BLAKE2B 934ab28e799d0d13c26c291005513511367eb2ddbeda0f9756c19f10fa9e6bb8e10451057fa7e0b49a30e3f562eb5f327057d324b2a92e09b1115f63132dca97 SHA512 d1fbf6e60e2df2c43d070bee6a9c1dc93c36a8ea7f75bbf2a67790840952661cee136ebccd6b2ed523ef9b7b56391e058384f2e3f46acb609bb362cac05b9753
+EBUILD hatari-2.1.0.ebuild 1951 BLAKE2B 256870db02e0c0cb6402157af5dc1a108f9dba4b3dbb414a7fa7d0ab3692877dd9baf0462f6a044e027a5d92d313fa479cee7251da75c8a87ed38d140897462b SHA512 7d6b881dfe3d1fbffb800b5ae866699891ee3cdfdbc88dc9633a755b1361d003ef1617648b8b30d1c72b709dc700fb9db4e3b3a5abc030270598b0035cad90d3
+MISC metadata.xml 318 BLAKE2B be4d8512e3f8fe751fc03aeae422216c9a366fc4cea3a49e4b8050f2a8280054fcc335f820718743fdf49cdb9a1fb73633e596ac8bf989b22f0f5a5fa33bd93b SHA512 2e304611622c91d0bd54f986ac3f02fc504bbd28e5ce03e5b958100b8567012ea0fe2a46884d29dfa18c6a4408fd0283679eb4a4f62c80a40ad748f5c811d943
diff --git a/games-emulation/hatari/hatari-2.1.0.ebuild b/games-emulation/hatari/hatari-2.1.0.ebuild
new file mode 100644
index 000000000000..92eba857519e
--- /dev/null
+++ b/games-emulation/hatari/hatari-2.1.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit toolchain-funcs cmake-utils python-single-r1
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/hatari/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sdl2"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ games-emulation/caps
+ sdl2? ( media-libs/libsdl2[X,sound,video] )
+ !sdl2? ( media-libs/libsdl[X,sound,video] )
+ media-libs/portaudio
+ media-libs/portmidi
+ sys-libs/readline:0=
+ media-libs/libpng:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]
+ >=games-emulation/emutos-0.9.9.1"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,
+has been installed in /usr/lib*/hatari with a .img extension (there
+are several from which to choose).
+Another option is to go to http://www.atari.st/ and get a real TOS:
+http://www.atari.st/
+The first time you run hatari, you should configure it to find the
+TOS you prefer to use. Be sure to save your settings.
+"
+
+DOCS="readme.txt doc/*.txt"
+HTML_DOCS="doc/"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i -e '/Encoding/d' ./python-ui/hatariui.desktop || die
+ sed -i -e "s/python/${EPYTHON}/" tools/atari-hd-image.sh || die
+ sed -i -e "s#@DOCDIR@#/usr/share/doc/${PF}/html/#" python-ui/uihelpers.py || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DDOCDIR=/usr/share/doc/${PF}"
+ "-DENABLE_SDL2=$(usex sdl2)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${ED%/}"/usr/share/hatari/{hatariui,hconsole}/
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/games-emulation/hatari/metadata.xml b/games-emulation/hatari/metadata.xml
new file mode 100644
index 000000000000..d4511e749d48
--- /dev/null
+++ b/games-emulation/hatari/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<use>
+ <flag name="sdl2">Use libsdl2 instead of libsdl</flag>
+</use>
+</pkgmetadata>