summaryrefslogtreecommitdiff
path: root/games-emulation/melonds/files/melonds-0.9.5-no-ccache-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/melonds/files/melonds-0.9.5-no-ccache-detection.patch')
-rw-r--r--games-emulation/melonds/files/melonds-0.9.5-no-ccache-detection.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/games-emulation/melonds/files/melonds-0.9.5-no-ccache-detection.patch b/games-emulation/melonds/files/melonds-0.9.5-no-ccache-detection.patch
new file mode 100644
index 000000000000..0a00b1057f58
--- /dev/null
+++ b/games-emulation/melonds/files/melonds-0.9.5-no-ccache-detection.patch
@@ -0,0 +1,16 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,13 +92,6 @@ endif()
+
+ set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
+-find_program(CCACHE "ccache")
+-if (CCACHE)
+- message(STATUS "Using CCache to speed up compilation")
+- set(CMAKE_C_COMPILER_LAUNCHER ${CCACHE})
+- set(CMAKE_CXX_COMPILER_LAUNCHER ${CCACHE})
+-endif()
+-
+ option(BUILD_QT_SDL "Build Qt/SDL frontend" ON)
+
+ add_subdirectory(src)