summaryrefslogtreecommitdiff
path: root/games-emulation/melonds
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/melonds')
-rw-r--r--games-emulation/melonds/Manifest4
-rw-r--r--games-emulation/melonds/melonds-0.9.5_p20241113.ebuild91
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild18
3 files changed, 99 insertions, 14 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 2e5692dd68d9..9a738bbb91b2 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1,4 +1,6 @@
DIST melonDS-0.9.5_p20240815.tar.gz 3400066 BLAKE2B c2e530ee12e1ba6cb9d7bc1ac233be984a00a9b182b4f8cab3082dad3b6e0449239455f422113ca8efcbcfafd8a4b8bca3b3dc84c79936e467f001b21b90f79d SHA512 7845be503f272aa2b7e070b19c46893274fc3d44ace3ae1ce11e33da8e58766127cb1c89dcb92bd8084f33a8cc7c0241b7416423ec93fe45858211cd69e1766e
+DIST melonDS-0.9.5_p20241113.tar.gz 3410057 BLAKE2B 6c4e5e8aa1a519a11308d42168c22d6fde8176fe46e96d00edcc34112e16d65aad77d1925b9f1966c198035cccae092902428081f1cf56d40eac30c369477433 SHA512 25b18547899e18e915cfdc0c437472fb39eeac520c478e232783fc5d57430e84b2cd0be1b2bcddfe9f5132877c8278ebb29893e7a104d7731974aa5e44f79914
EBUILD melonds-0.9.5_p20240815.ebuild 1907 BLAKE2B 9c925a38fd83482a86cff8fce6643ba6f80de59e4fe3278ac8fef69f2ea48d8c9085d4d3c5b8f6942838a5dca58bbcfe77fd5efe4c40dba8675e6d12b82ccf7f SHA512 1fe3e96e59ae3aa2b21dc30efc75628e3126871d5ef17158cd778c8c1e1b7b09090a41f4023ce5d9c247e58209626d3f70571570782db5d58d6a0723cc17d307
-EBUILD melonds-9999.ebuild 1811 BLAKE2B e16d80541b1f9c2009168421a216d2de4e3869324090bf84bd95b846c7b4872832a0c370993728dddce3c3495af2f278c54a856abfcd35c4ec2ab7a5a25ae56b SHA512 20926a1635d4891567f702461d934b056aa5d719a03589c8d4929b6e02613930f7b2d8d0462198cbc3d24ebf246a042a99e07e47aa9aecc13209761034f5cd92
+EBUILD melonds-0.9.5_p20241113.ebuild 1820 BLAKE2B 6848f802097558ffa902caaf2e4fcc71afd4aff951110252fafa0078e1ee81163db7774ea540ab0e2a90836f632c4c2179f5bded1a3afe6124164855f831ef48 SHA512 5ee8115823f90612410b5e482dcf7b05906b04d5de10515679122e2de62550417a8887f0288ae1630d22d5f42abccfaa662951b6d5bcbccf7b2e900734da4c26
+EBUILD melonds-9999.ebuild 1723 BLAKE2B aea56a4c7b95947df532958dc4e6c9b93168e3abc2d2f979d006642b1922bde3b0e3422d2f72ad0b8d4b07b4d3b4c824e65e307da72534617e5c631e8934ba8c SHA512 5d471a884d3d6c0018d9556e2786ddaa4a8e48499862674d4a8726b2e6d26ac30c2ef753b2c6bf7e3a918425788c9535ac247a6e1ce6749c1b53751de27f7389
MISC metadata.xml 404 BLAKE2B e9abe00b5ee8196030846be4e7a9e224c0fb7356f88a39949b219bb7355bcac50f6ca28b299a40f056e5a105903cb156aed77731fb3ed61d2ef88becf35d0dc3 SHA512 6e2926035441d9c93759ad92cb2c026a10d28b8354e90d56361b4afc1aa6e7f0e4bb49900ad9f6025f8f9b7070df5691583074f30620196f1305919bd7cfdbdb
diff --git a/games-emulation/melonds/melonds-0.9.5_p20241113.ebuild b/games-emulation/melonds/melonds-0.9.5_p20241113.ebuild
new file mode 100644
index 000000000000..3494d438a060
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.5_p20241113.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="melonDS"
+REAL_P="${REAL_PN}-${PV}"
+
+[[ "${PV}" == *p20241113 ]] && COMMIT="5e8beb3ab7277e0fae9a9a1cae8d26a357c570e5"
+
+inherit cmake readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${COMMIT}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${COMMIT}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+IUSE="+jit +opengl wayland"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-qt/qtbase:6[network,opengl,widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtsvg:6
+ media-libs/libsdl2[sound,video]
+ net-libs/enet:=
+ net-libs/libpcap
+ net-libs/libslirp
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
+"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be extracted from devices or found somewhere on the Internet ;-)"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ -DUSE_SYSTEM_LIBSLIRP=ON
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index e20ccdc8096e..088c19006bc0 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
REAL_PN="melonDS"
REAL_P="${REAL_PN}-${PV}"
-inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
+inherit cmake readme.gentoo-r1 toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="http://melonds.kuribo64.net
@@ -30,11 +30,9 @@ IUSE="+jit +opengl wayland"
RDEPEND="
app-arch/libarchive
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
+ dev-qt/qtbase:6[network,opengl,widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtsvg:6
media-libs/libsdl2[sound,video]
net-libs/enet:=
net-libs/libpcap
@@ -64,19 +62,13 @@ DOC_CONTENTS="You need the following files in order to run melonDS:
Place them in ~/.config/melonDS
Those files can be extracted from devices or found somewhere on the Internet ;-)"
-src_prepare() {
- filter-lto
- append-flags -fno-strict-aliasing
-
- cmake_src_prepare
-}
-
src_configure() {
local -a mycmakeargs=(
-DBUILD_SHARED_LIBS="OFF"
-DENABLE_JIT="$(usex jit)"
-DENABLE_OGLRENDERER="$(usex opengl)"
-DENABLE_WAYLAND="$(usex wayland)"
+ -DUSE_SYSTEM_LIBSLIRP=ON
)
cmake_src_configure
}