summaryrefslogtreecommitdiff
path: root/games-emulation/nestopia/nestopia-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/nestopia/nestopia-9999.ebuild')
-rw-r--r--games-emulation/nestopia/nestopia-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/games-emulation/nestopia/nestopia-9999.ebuild b/games-emulation/nestopia/nestopia-9999.ebuild
index c6bdbe0d6fb8..646a1b125a96 100644
--- a/games-emulation/nestopia/nestopia-9999.ebuild
+++ b/games-emulation/nestopia/nestopia-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools xdg
+inherit autotools flag-o-matic xdg
DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
HOMEPAGE="http://0ldsk00l.ca/nestopia/"
@@ -38,5 +38,8 @@ src_prepare() {
}
src_configure() {
+ # silence the narrowing warnings on clang (#830469)
+ append-cxxflags -Wno-narrowing
+
econf $(use_enable doc)
}