summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2_patches
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2_patches')
-rw-r--r--games-emulation/pcsx2_patches/Manifest2
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20240714.ebuild58
2 files changed, 0 insertions, 60 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index c7d38a121fc0..23d6d128a0a4 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1,6 +1,4 @@
-DIST pcsx2_patches-0_p20240714.tar.gz 675035 BLAKE2B 6ed77089ba630bfd37f9eb7372855ed638b8c8c5a9788b6a6ddcdcfff4e1d53b03fe7160c8bd7780ea13b9bd63a4cc7a2e1ac0410f447b1e17a42598d19fe348 SHA512 15f89e40944d56b301aa33235236898532a888af4f3c0f3527e6c98eb38039f6b7623b60c0aadb2f4a7a7b1bc325cb60f84b6d16b3d3066c0e924ff040ed8e50
DIST pcsx2_patches-0_p20241020.tar.gz 684434 BLAKE2B 934b0953d845cdc3e85bb99c7ec9ad8d251137d694287d487f8bfcfea048e5e572285e863b7d9e1c1650f07cd89bd69ca72259d357c92732e942aad4c975fc2f SHA512 5b4d8e545a9694966fda0aa96a1198ce0be66d163ef1d033b3ae054e01457b570f1e10b1d5f7657a54d4a6526d1f039a1a382e95531797208ea7b31b96aebbad
-EBUILD pcsx2_patches-0_p20240714.ebuild 1638 BLAKE2B 3835f4cf8ab74305ed72f25587b9016d8811c2810fd87b82ae825e917b0665040b334032c767b6dbaf519c2893aa70125199cf1e79f900934299c1df81669276 SHA512 70b503cc35f473ab3c2cd370ed71198089c20a79b925bc87707e4c0af81de0523107af2f22fe97e6cec28e3888001539441de3031c64332c204dcbf55c2c45cf
EBUILD pcsx2_patches-0_p20241020.ebuild 1640 BLAKE2B da7cb2fcaba85b4a18fc02da6ec2c1d56fe1a92a07ece4d3d4366be69b44a9c25b4a5a17ef61e119fa1c872bd1e3b12928b2c28b8985b7ca0902aad47adc43c8 SHA512 146fddf06ec21138c93dcbb33f54bafc88203f72e5f1589b4bbdc4b1c15e301f22d8fc3e6d67f36a33d4d2786859281bc4c8be1d9627a3493df234cf5a9a3750
EBUILD pcsx2_patches-9999.ebuild 1601 BLAKE2B 7c74c00cf0b638adaed95035510d730fee4642306bf521c9e20238867740daa408dbd701c5275ff9c36c8c8eee0c298aba7407a66e35c23a6a487cbc10afeec3 SHA512 a111d168cd345f538612d88945e28b63cf777c86093f4aa39f0cbbad52ece87f5807676457cd632f98b1ba622802c75094257205d1f87e55de0d6b7f5a7cb999
MISC metadata.xml 362 BLAKE2B 3b213785f8a28bc1e2f540e27b025d4397dec5f7885fcc8f7e3fa56186b8f023ef97de5ff7b927a8c09ad1f79baee546d08b25cf865e344197a1640470f37641 SHA512 f00b1d14ba779989c235775de6f2470e18b29f2813723eae51015681af2d2c798aeddaa9657897c83b8bcb0b124ea77b34cf6370e37104fa24a968834ea5fabb
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240714.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240714.ebuild
deleted file mode 100644
index abdf31ed2c23..000000000000
--- a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20240714.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# note: not "required" but should typically be bumped at same
-# time as pcsx2 to match the patches.zip shipped with it
-
-PYTHON_COMPAT=( python3_{10..13} )
-inherit python-any-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
-else
- HASH_PCSX2_PATCHES=afb17c4d851c54f93d4249e1e1dc8c57e2d0e6c6
- SRC_URI="
- https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
- -> ${P}.tar.gz
- "
- S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
- KEYWORDS="amd64"
-fi
-
-DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
-HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
-
-# these are normally distributed by upstream with PCSX2 which is GPL-3+
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="${PYTHON_DEPS}"
-
-src_compile() {
- # upstream uses a constantly replaced "latest" patches.zip (currently no
- # real releases), and github's .zip archives cannot be used either due to
- # having the patches/ subdirectory -- so we use a snapshot and repack
- # (could use app-arch/zip, but python is more likely to skip a dependency)
- ebegin "Creating patches.zip"
- "${PYTHON}" - <<-EOF
- import pathlib
- from zipfile import ZipFile, ZIP_DEFLATED
-
- patches = pathlib.Path("patches/")
-
- with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
- for file in patches.iterdir():
- archive.write(file, arcname=file.name)
- EOF
- eend ${?} || die
-}
-
-src_install() {
- insinto /usr/lib/pcsx2/resources
- doins patches.zip
-
- einstalldocs
-}