summaryrefslogtreecommitdiff
path: root/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild')
-rw-r--r--games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild b/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
index 68bb3ae1edc8..f9054d23eec3 100644
--- a/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
+++ b/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit desktop toolchain-funcs
MY_PN=Nexuiz
@@ -87,7 +88,13 @@ src_prepare() {
}
src_compile() {
+ # Unset STRIP because the build system by default will not strip
+ # If users express a preference, this triggers strip
+ # bug #739294
+ unset STRIP
+
tc-export CC
+
if use opengl || ! use dedicated ; then
emake cl-${PN}
if use sdl ; then