summaryrefslogtreecommitdiff
path: root/games-misc/fortune-mod-osfortune/fortune-mod-osfortune-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/fortune-mod-osfortune/fortune-mod-osfortune-1.ebuild')
-rw-r--r--games-misc/fortune-mod-osfortune/fortune-mod-osfortune-1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-misc/fortune-mod-osfortune/fortune-mod-osfortune-1.ebuild b/games-misc/fortune-mod-osfortune/fortune-mod-osfortune-1.ebuild
new file mode 100644
index 000000000000..1d5dec303346
--- /dev/null
+++ b/games-misc/fortune-mod-osfortune/fortune-mod-osfortune-1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Open sources fortune file"
+HOMEPAGE="http://www.dibona.com/opensources/index.shtml"
+SRC_URI="http://www.dibona.com/opensources/osfortune.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa m68k ~mips ppc64 s390 sh x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="games-misc/fortune-mod"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/spelling.patch
+ strfile osfortune || die
+}
+
+src_install() {
+ insinto /usr/share/fortune
+ doins osfortune osfortune.dat
+}