summaryrefslogtreecommitdiff
path: root/games-misc/ponysay/ponysay-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/ponysay/ponysay-3.0.3.ebuild')
-rw-r--r--games-misc/ponysay/ponysay-3.0.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/games-misc/ponysay/ponysay-3.0.3.ebuild b/games-misc/ponysay/ponysay-3.0.3.ebuild
index 5c758bbc2106..00fedbca4e25 100644
--- a/games-misc/ponysay/ponysay-3.0.3.ebuild
+++ b/games-misc/ponysay/ponysay-3.0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit bash-completion-r1 python-single-r1
DESCRIPTION="cowsay reimplemention for ponies"
@@ -22,6 +22,10 @@ RDEPEND="${PYTHON_DEPS}
fish-completion? ( app-shells/fish )
zsh-completion? ( app-shells/zsh )"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.3-python-syntax.patch"
+)
+
setup_py() {
"${PYTHON}" setup.py \
--prefix="${EPREFIX}"/usr \