summaryrefslogtreecommitdiff
path: root/games-puzzle/amoebax/amoebax-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/amoebax/amoebax-0.2.1.ebuild')
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-puzzle/amoebax/amoebax-0.2.1.ebuild b/games-puzzle/amoebax/amoebax-0.2.1.ebuild
new file mode 100644
index 000000000000..2d9537adeacb
--- /dev/null
+++ b/games-puzzle/amoebax/amoebax-0.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="a cute and addictive action-puzzle game, similar to tetris"
+HOMEPAGE="http://www.emma-soft.com/games/amoebax/"
+SRC_URI="http://www.emma-soft.com/games/amoebax/download/${P}.tar.bz2"
+
+LICENSE="FreeArt GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-aclocal.patch \
+ "${FILESDIR}"/${P}-compile.patch
+
+ sed -i \
+ -e "/^SUBDIRS/s:doc ::" \
+ Makefile.am || die
+ sed -i \
+ -e "/^iconsdir/s:=.*:=/usr/share/pixmaps:" \
+ -e "/^desktopdir/s:=.*:=/usr/share/applications:" \
+ data/Makefile.am || die
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Icon/s/.svg//' \
+ data/amoebax.desktop || die
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}