summaryrefslogtreecommitdiff
path: root/games-puzzle/sdl-jewels/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/sdl-jewels/files')
-rw-r--r--games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch b/games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch
new file mode 100644
index 000000000000..ba27fd5447bf
--- /dev/null
+++ b/games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch
@@ -0,0 +1,17 @@
+--- SDL_jewels-1.1.1/Makefile.old 2010-11-13 00:46:47.196000082 +0000
++++ SDL_jewels-1.1.1/Makefile 2010-11-13 01:45:14.516000087 +0000
+@@ -1,11 +1,12 @@
+ EXE = gljewel
+
+-CFLAGS = -O2 -Wall $(shell sdl-config --cflags)
+-LDFLAGS = $(shell sdl-config --libs) -lGL -lm
++CFLAGS += -Wall $(shell sdl-config --cflags)
++LIBS = $(shell sdl-config --libs) -lGL -lm
+
+ OBJS = $(EXE).o matrix.o sound.o
+
+ $(EXE): $(OBJS)
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ $(EXE).o: $(EXE).c matrix.h misc.h
+