summaryrefslogtreecommitdiff
path: root/games-puzzle/seatris/seatris-0.0.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/seatris/seatris-0.0.14.ebuild')
-rw-r--r--games-puzzle/seatris/seatris-0.0.14.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/seatris/seatris-0.0.14.ebuild b/games-puzzle/seatris/seatris-0.0.14.ebuild
new file mode 100644
index 000000000000..19c5e07f0822
--- /dev/null
+++ b/games-puzzle/seatris/seatris-0.0.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A color ncurses tetris clone"
+HOMEPAGE="http://www.earth.li/projectpurple/progs/seatris.html"
+SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "s:/var/lib/games:${GAMES_STATEDIR}:" \
+ scoring.h seatris.6 || die
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ emake LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}
+
+src_install () {
+ dogamesbin seatris
+ doman seatris.6
+ dodoc ACKNOWLEDGEMENTS HISTORY README TODO example.seatrisrc
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}${GAMES_STATEDIR}/seatris.score"
+ fperms 660 "${GAMES_STATEDIR}/seatris.score"
+ prepgamesdirs
+}