summaryrefslogtreecommitdiff
path: root/games-roguelike/hengband/hengband-1.6.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/hengband/hengband-1.6.2-r1.ebuild')
-rw-r--r--games-roguelike/hengband/hengband-1.6.2-r1.ebuild70
1 files changed, 39 insertions, 31 deletions
diff --git a/games-roguelike/hengband/hengband-1.6.2-r1.ebuild b/games-roguelike/hengband/hengband-1.6.2-r1.ebuild
index 97f4b9bd3cb7..e6fb57c68472 100644
--- a/games-roguelike/hengband/hengband-1.6.2-r1.ebuild
+++ b/games-roguelike/hengband/hengband-1.6.2-r1.ebuild
@@ -1,62 +1,70 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools games
+EAPI=7
+
+inherit autotools
DESCRIPTION="An Angband variant, with a Japanese/fantasy theme"
HOMEPAGE="http://hengband.sourceforge.jp/en/"
SRC_URI="mirror://sourceforge.jp/hengband/10331/${P}.tar.bz2
mirror://gentoo/${P}-mispellings.patch.gz"
-KEYWORDS="~x86"
LICENSE="Moria"
SLOT="0"
+KEYWORDS="~x86"
IUSE="X l10n_ja"
-RDEPEND=">=sys-libs/ncurses-5:0
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-libs/libXt )"
+RDEPEND="
+ >=sys-libs/ncurses-5:0=
+ X? ( x11-libs/libX11 )
+"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-libs/libXt )
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.2-added_faq.patch"
+ "${FILESDIR}/${PN}-1.6.2-autoconf-ncurses.patch"
+ "${FILESDIR}/${PN}-1.6.2-ovflfix.patch"
+)
src_prepare() {
# Removing Xaw dependency as is not used
- sed -i \
- -e '/Xaw/d' src/main-xaw.c \
- || die
- sed -i \
- -e 's|root\.|root:|' lib/*/Makefile.in \
- || die
- sed -i \
- -e 's:/games/:/:g' configure.in \
- || die
- epatch \
- "../${P}"-mispellings.patch \
- "${FILESDIR}/${P}"-added_faq.patch \
- "${FILESDIR}"/${P}-ovflfix.patch
+ sed -i -e '/Xaw/d' src/main-xaw.c || die
+ # Fix syntax for chown
+ sed -i -e 's|root\.|root:|' lib/*/Makefile.in || die
+ # Don't target the games sub-dir, since we're not using games.eclass any
+ # more
+ sed -i -e 's:/games/:/:g' configure.in || die
+
+ default
+
mv configure.in configure.ac || die
+
eautoreconf
}
src_configure() {
- local myconf
- use l10n_ja || myconf="--disable-japanese"
+ local myconf=(
+ --bindir="${EPREFIX}"/usr/bin
+ --with-setgid="nobody"
+ $(use_with X x)
+ )
+ use l10n_ja || myconf+=( --disable-japanese )
- egamesconf \
- --with-setgid=${GAMES_GROUP} \
- $(use_with X x) \
- ${myconf}
+ econf "${myconf[@]}"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ default
+
if use l10n_ja ; then
dodoc readme.txt autopick.txt readme_eng.txt autopick_eng.txt
else
newdoc readme_eng.txt readme.txt
newdoc autopick_eng.txt autopick.txt
fi
- prepgamesdirs
- # FIXME: we need to patch around this BS
- fperms g+w "${GAMES_DATADIR}"/${PN}/lib/{apex,data,save,user}
}