summaryrefslogtreecommitdiff
path: root/games-rpg/freedroidrpg
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/freedroidrpg')
-rw-r--r--games-rpg/freedroidrpg/Manifest3
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-0.16-r1.ebuild86
-rw-r--r--games-rpg/freedroidrpg/metadata.xml54
3 files changed, 143 insertions, 0 deletions
diff --git a/games-rpg/freedroidrpg/Manifest b/games-rpg/freedroidrpg/Manifest
new file mode 100644
index 000000000000..2e13858b90e8
--- /dev/null
+++ b/games-rpg/freedroidrpg/Manifest
@@ -0,0 +1,3 @@
+DIST freedroidRPG-0.16.tar.gz 225570013 BLAKE2B ad87ad3d368c94eb1f3dae2d4c3df97b9bc88acccbec4cbcd31e42b411bb96506faac23f8de9b0317a1ab926b34bd01196adce617ab7b731354049d3fb010643 SHA512 039ee4bfcd58e29a3cfa26ae7f2bc8aed7c289119476bb8f8486006910cf6a2127ba49f7526fac887392ca9e5320fb1a59ba068834e162348905423908b0755a
+EBUILD freedroidrpg-0.16-r1.ebuild 1781 BLAKE2B 4ab53881ba87e23fd60353a9f303eb321ca9cfddec398c5e43dd1c51d4939803c0ce60491389c62304efa7159ce2c7452d25de27241a9131275425741c8a255b SHA512 2f4df51a1208eb76f03d830d671f8433bdb2a0c03ed99c06fb1af4e1be8e6e4c09dd566f7bf6faddf6dbf81c1c6c20e80087fbd7cd2e3fe51fbacb0d02fa90ec
+MISC metadata.xml 2288 BLAKE2B e60e49e0140a270511938adc92ee1d0498590c0daff8fc26ab1451a29bb1ede358991da211f821b04d9432c6792335e18c328aeb8c6613b9b3a87954ba8b2c8d SHA512 196a3711abe685277462235c912a41b46dc8fa5122d611f4f864300262ae888611951451162db87e75eafa7720d662a1fc51e4441b0d9fb730109f6c2c4aadca
diff --git a/games-rpg/freedroidrpg/freedroidrpg-0.16-r1.ebuild b/games-rpg/freedroidrpg/freedroidrpg-0.16-r1.ebuild
new file mode 100644
index 000000000000..cdde16dcc8f2
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-0.16-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools eutils gnome2-utils python-any-r1
+
+DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="http://freedroid.sourceforge.net/"
+SRC_URI="ftp://ftp.osuosl.org/pub/freedroid/freedroidRPG-${PV}//freedroidRPG-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl sound"
+
+RDEPEND="
+ virtual/jpeg:0
+ media-libs/libpng:0
+ media-libs/libsdl[opengl?,sound?,video]
+ >=media-libs/sdl-gfx-2.0.21
+ media-libs/sdl-image[jpeg,png]
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ sound? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/sdl-mixer[vorbis] )
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^dist_doc_DATA/d' \
+ -e '/-pipe/d' \
+ -e '/^SUBDIRS/s/pkgs//' \
+ Makefile.am || die
+ python_fix_shebang src sound
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fastmath \
+ --with-embedded-lua \
+ --localedir=/usr/share/locale \
+ $(use_enable nls) \
+ $(use_enable opengl) \
+ $(use_enable sound)
+}
+
+src_install() {
+ local i
+
+ default
+ for i in 48 64 96 128
+ do
+ doicon -s ${i} pkgs/freedesktop/icons/hicolor/${i}x${i}/apps/freedroidRPG.png
+ done
+ doicon -s scalable pkgs/freedesktop/icons/hicolor/scalable/apps/freedroidRPG.svg
+ make_desktop_entry freedroidRPG "Freedroid RPG" freedroidRPG
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ echo
+ ewarn "${P} is not compatible with old save games."
+ ewarn "Please start a new character."
+ echo
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/freedroidrpg/metadata.xml b/games-rpg/freedroidrpg/metadata.xml
new file mode 100644
index 000000000000..d9e96aa7715a
--- /dev/null
+++ b/games-rpg/freedroidrpg/metadata.xml
@@ -0,0 +1,54 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+Hello, and welcome to the Freedroid page.
+
+THE CLASSICAL FREEDROID: Freedroid is a clone of the classic game
+"Paradroid" on Commodore 64 with some improvements and extensions to
+the classic version.
+
+In this game, you control a robot, depicted by a small white ball with
+a few numbers within an interstellar spaceship consisting of several
+decks connected by elevators.
+
+The aim of the game is to destroy all enemy robots, depicted by small
+black balls with a few numbers, by either shooting them or seizing
+control over them by creating connections in a short subgame of
+electric circuits.
+
+Development of this game is now complete. The final version came out
+in august 2003 and runs on Linux, Mac OSX, Sharp Zaurus and even that
+strange Windows wannabe of an operating system. Thanks to all who
+helped.
+Minor fixes and maintainance will of course still continue though...
+
+FREEDROID RPG: The Freedroid RPG is an extension/modification of the
+classical freedroid engine into an RPG. The main differences to the
+classical version are as follows:
+* The Tux is the main character of the rpg. He is not displayed as a
+ ball like in Freedroid but rather as an animated character, while
+ other droids and humans in the game are still represented as the balls
+ with some number or code in them.
+* Dialogs and chatting with friendly droids and humans:
+ Multiple-choice menus and voice samples (with subtitles for those
+ without sound).
+* Melee weapons, armour and other items to be equipped have been
+ added.
+* An automap feature was added.
+* Saving and loading of games.
+* A shop to trade things.
+* Controls are different: Mouse can be used to do everything.
+ Joystick is not supported for moving around any more.
+* The archive size (including sound samples) is about 10 times as big
+ as for the classical version. I'd like to appologize to all 56K modem
+ owners at this point.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">freedroid</remote-id>
+ </upstream>
+</pkgmetadata>