summaryrefslogtreecommitdiff
path: root/games-rpg/gwiz/gwiz-0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/gwiz/gwiz-0.8.ebuild')
-rw-r--r--games-rpg/gwiz/gwiz-0.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-rpg/gwiz/gwiz-0.8.ebuild b/games-rpg/gwiz/gwiz-0.8.ebuild
new file mode 100644
index 000000000000..ddd60d95f866
--- /dev/null
+++ b/games-rpg/gwiz/gwiz-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils flag-o-matic games
+
+DESCRIPTION="clone of old-school Wizardry(tm) games by SirTech"
+HOMEPAGE="http://icculus.org/gwiz/"
+SRC_URI="http://icculus.org/gwiz/${P}.tar.bz2"
+
+KEYWORDS="~alpha amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.3[joystick,video]
+ >=media-libs/sdl-image-1.2.1-r1[png]
+ >=media-libs/sdl-ttf-2.0.4"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buffer.patch
+ append-cflags -std=gnu89 # build with gcc5 (bug #572532)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README doc/HOWTO-PLAY" \
+ default
+ newicon pixmaps/gwiz_icon.xpm ${PN}.xpm
+ make_desktop_entry gwiz Gwiz
+}