summaryrefslogtreecommitdiff
path: root/games-strategy/s25rttr/files
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/s25rttr/files')
-rw-r--r--games-strategy/s25rttr/files/s25rttr-loosen-libs.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/games-strategy/s25rttr/files/s25rttr-loosen-libs.patch b/games-strategy/s25rttr/files/s25rttr-loosen-libs.patch
new file mode 100644
index 000000000000..421cde2cd74f
--- /dev/null
+++ b/games-strategy/s25rttr/files/s25rttr-loosen-libs.patch
@@ -0,0 +1,13 @@
+diff --git a/libs/libGamedata/CMakeLists.txt b/libs/libGamedata/CMakeLists.txt
+index b09569530..3d908226c 100644
+--- a/libs/libGamedata/CMakeLists.txt
++++ b/libs/libGamedata/CMakeLists.txt
+@@ -12,7 +12,7 @@ FILE(GLOB SOURCES_OTHER *.cpp *.h)
+ SOURCE_GROUP(other FILES ${SOURCES_OTHER})
+
+ # CMake < 3.2 treats version 5.2.x as not equal to 5.2 but we want to allow all 5.2 versions
+-find_package(Lua 5.2 EXACT REQUIRED)
++find_package(Lua 5.1 REQUIRED)
+
+ include(GatherDll)
+ gather_dll(Lua)