summaryrefslogtreecommitdiff
path: root/games-util/fteqcc/fteqcc-2501.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/fteqcc/fteqcc-2501.ebuild')
-rw-r--r--games-util/fteqcc/fteqcc-2501.ebuild31
1 files changed, 14 insertions, 17 deletions
diff --git a/games-util/fteqcc/fteqcc-2501.ebuild b/games-util/fteqcc/fteqcc-2501.ebuild
index c03aa1ac4ee1..3791f964ea75 100644
--- a/games-util/fteqcc/fteqcc-2501.ebuild
+++ b/games-util/fteqcc/fteqcc-2501.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils flag-o-matic
+EAPI=7
+
+inherit edos2unix toolchain-funcs
DESCRIPTION="QC compiler"
HOMEPAGE="http://fteqw.sourceforge.net/"
@@ -11,28 +12,24 @@ SRC_URI="mirror://sourceforge/fteqw/qclibsrc${PV}.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RESTRICT="test"
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
-S=${WORKDIR}
+PATCHES=(
+ "${FILESDIR}"/${P}-cleanup-source.patch
+ "${FILESDIR}"/${P}-Makefile.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-cleanup-source.patch
- sed -i \
- -e '/^CC/d' \
- -e "s: -O3 : :g" \
- -e "s: -s : :g" \
- -e 's/-o fteqcc.bin/$(LDFLAGS) -o fteqcc.bin/' \
- Makefile || die "sed failed"
+ default
edos2unix readme.txt
- append-flags -DQCCONLY
}
-src_compile() {
- emake BASE_CFLAGS="${CFLAGS} -Wall"
+src_configure() {
+ tc-export CC
}
src_install() {