summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7909 -> 7908 bytes
-rw-r--r--games-util/lutris/Manifest4
-rw-r--r--games-util/lutris/lutris-0.5.18.ebuild158
-rw-r--r--games-util/lutris/lutris-9999.ebuild1
4 files changed, 162 insertions, 1 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 7421284d2e6a..59608ad5ed44 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 68905bff2f53..b24ef07fb59f 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,4 +1,6 @@
DIST lutris-0.5.17.gh.tar.gz 1659770 BLAKE2B 913727515b9117bb9150b7af04bbecfc6d816dd119e1aea376ef24d0e89b875f572ae8d0fdd4b4be410f1a96543a11217b2abfb2989113038fe9aace7c88158f SHA512 1c210650bff71a942069a953e2061c482117762c170906811cbc4743d4dbf3032ac6fc280c6f972c881349e4ed8652473e4c808c0ce4e8508d03216d8c4875cd
+DIST lutris-0.5.18.gh.tar.gz 1737549 BLAKE2B c5ebe512de2bdf8df3b9ac22a965fab458301ad82bc1dce0cd5690d13fce6686c03c2da50c93d0b283b6bfe0e1a6ea16623c7191a3a9f1b60af26e0d370dc926 SHA512 22c5bba8cc7eaa03b41de94ad15029515e3e19d0881e5e3250c603e40503bcb30591076df2b20bad3683c78be45328a3c782b0194a493196d3cc4e1814839c89
EBUILD lutris-0.5.17-r1.ebuild 6502 BLAKE2B bb1408d04ff52feb7b6d58ecad86facb35d1c97dc4ab37b027c0070a14b7c80b879505c20747acf78382c4b7effdd8dcea30490a333ffe1eed1a54e42520e40d SHA512 3cb483111339e4327ad128cee60adf47079d9759089a9cb734be387fb87ab1cf713d839ac8fa771b2511ed701a33209592292a3bb1b4108d69d30ee202ff86cf
-EBUILD lutris-9999.ebuild 6461 BLAKE2B db985cc733f385cacb3947704da253b19436b6ed807bac1307adf821e4e220f5ec9cbcc6c1598aa354fa895887d3a6fb929a7e714f2697f0bd28fd1b5f8807ca SHA512 a961d0c7f634d29adcfb46abb82be2b05723b23ed3d21f712bba6dd64f8bb370856f89ea9d2ca7b12bc00e49a4dff301d968a59c9c2e08b7854bac2f1d0f627c
+EBUILD lutris-0.5.18.ebuild 6502 BLAKE2B bb1408d04ff52feb7b6d58ecad86facb35d1c97dc4ab37b027c0070a14b7c80b879505c20747acf78382c4b7effdd8dcea30490a333ffe1eed1a54e42520e40d SHA512 3cb483111339e4327ad128cee60adf47079d9759089a9cb734be387fb87ab1cf713d839ac8fa771b2511ed701a33209592292a3bb1b4108d69d30ee202ff86cf
+EBUILD lutris-9999.ebuild 6502 BLAKE2B bb1408d04ff52feb7b6d58ecad86facb35d1c97dc4ab37b027c0070a14b7c80b879505c20747acf78382c4b7effdd8dcea30490a333ffe1eed1a54e42520e40d SHA512 3cb483111339e4327ad128cee60adf47079d9759089a9cb734be387fb87ab1cf713d839ac8fa771b2511ed701a33209592292a3bb1b4108d69d30ee202ff86cf
MISC metadata.xml 768 BLAKE2B a55b857df33b651314be823f9ef0032e0120bc4ce3ea7f13950b01d0f3fdb5300d4e93e6e74bdb11aaf4d88195d91fa4915ffdd8390c12f1552f127f9bd910d2 SHA512 40dee1f6f5f2de1a08ffd809161519b31b338c99933687fd5453e1714d8ec318a468a27e79ce22913328af53992b71aa4fc5921ed2a8dd57e8a8a6e154b2b144
diff --git a/games-util/lutris/lutris-0.5.18.ebuild b/games-util/lutris/lutris-0.5.18.ebuild
new file mode 100644
index 000000000000..765674cdc319
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.18.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+inherit meson python-single-r1 optfeature virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ if [[ ${PV} != *_beta* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+ fi
+fi
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/evdev[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pypresence[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/protobuf[${PYTHON_USEDEP}]
+ dev-python/moddb[${PYTHON_USEDEP}]
+ ')
+ media-sound/fluid-soundfont
+ || (
+ net-libs/webkit-gtk:4[introspection]
+ net-libs/webkit-gtk:4.1[introspection]
+ )
+ sys-apps/pciutils
+ sys-apps/xdg-desktop-portal
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gdk-pixbuf[jpeg]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
+
+EPYTEST_IGNORE=(
+ # Requires a Nvidia GPU and driver
+ tests/util/graphics/test_drivers.py
+)
+
+src_test() {
+ meson_src_test
+ virtx epytest
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}/usr/" #740048
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "playing various games through Valve's Steam launcher (available in Steam overlay)" games-util/steam-launcher
+ optfeature "playing games through Valve's micro-compositor" gui-wm/gamescope
+ optfeature "playing games inside a nested X server" x11-base/xorg-server[xephyr]
+ optfeature "installing and playing games from Flathub" sys-apps/flatpak
+ optfeature "playing Microsoft Windows games" virtual/wine
+ optfeature "playing DirectX based games by translating DirectX to Vulkan" "media-libs/vulkan-loader dev-util/vulkan-tools app-emulation/dxvk virtual/wine"
+ optfeature "playing Vulkan based games (plus ICD for your hardware)" "media-libs/vulkan-loader dev-util/vulkan-tools"
+ optfeature "a Vulkan and OpenGL overlay for monitoring system performance (available in GURU overlay)" games-util/mangohud
+ elog
+
+ optfeature_header "${PN} supports various emulators and compatibility layers. \n${PN} can download and install these by itself, but also supports using system-wide installed versions"
+ optfeature "playing games through x86 PC emulator" app-emulation/86Box
+ # TODO: Package Adventure Game Studio runner
+ optfeature "playing Atari 800 games through an emulator" games-emulation/atari800
+ # TODO: Package Basilisk II Mac emulator
+ # TODO: Package Wii U emulator
+ optfeature "playing Nintendo 3DS games through an emulator (available in GURU overlay)" games-emulation/citra
+ # TODO: Package ColecoVision/Coleco Adam emulator
+ optfeature "playing Nintendo DS games through an emulator" games-emulation/desmume
+ optfeature "playing Sega Genesis games through an emulator" games-emulation/dgen-sdl
+ optfeature "playing GameCube and Wii games through an emulator" games-emulation/dolphin
+ optfeature "playing DOS games through an emulator" games-emulation/dosbox
+ optfeature "playing RPG Maker 2000/2003 games (available in GURU overlay)" games-engines/easyrpg-player
+ optfeature "playing Z-code based text games" games-engines/frotz
+ optfeature "playing Amiga games through an emulator" app-emulation/fs-uae
+ optfeature "playing Atari ST games through an emulator" games-emulation/hatari
+ # TODO: Package Intellivision emulator
+ optfeature "playing games through various emulators" games-emulation/libretro-info
+ optfeature "playing Arcade games through an emulator" games-emulation/advancemame
+ optfeature "playing games through various emulators" games-emulation/mednafen
+ optfeature "playing Nintendo DS games through an emulator" games-emulation/melonds
+ # TODO: Package mGBA
+ # TODO: Package MicroM8 Apple II emulator
+ # TODO: Package Mini vMac emulator
+ optfeature "playing Nintendo 64 games through an emulator" games-emulation/mupen64plus
+ # TODO: Package O2Em emulator
+ # TODO: Package Sega Master System emulator
+ optfeature "playing IBM PC games through an emulator" app-emulation/pcem
+ optfeature "playing Sony PlayStation 2 games through an emulator" games-emulation/pcsx2
+ optfeature "playing various fantasy games" dev-lang/pico8
+ optfeature "playing Sony PlayStation Portable games through an emulator" games-emulation/ppsspp
+ # TODO: Package SEGA Dreamcast emulator redream
+ # TODO: Package SEGA Dreamcast emulator reicast
+ # TODO: Package Rosalie's Mupen GUI
+ optfeature "playing Sony PlayStation 3 games through an emulator (available in GURU overlay)" games-emulation/rpcs3
+ optfeature "playing Adobe Flash Player games through an emulator" app-emulation/ruffle
+ # TODO: Package Nintendo Switch emulator
+ optfeature "playing Lucasarts adventure games" games-engines/scummvm
+ # TODO: Package PowerMacintosh emulator
+ optfeature "playing Super Nintendo (SNES) games through an emulator" games-emulation/snes9x
+ # TODO: Package Sinclair ZX Spectrum emulator
+ optfeature "playing Atari 2600 VCS games through an emulator" games-emulation/stella
+ # TODO: Package TIC-80 tiny computer
+ optfeature "playing Commodore games through an emulator" app-emulation/vice
+ # TODO: Package Atari Jaguar emulator
+ # TODO: Package Vita3K PS Vita emulator
+ # TODO: Package runner for HTML5 web games
+ # TODO: Package Xbox emulator
+ optfeature "playing Nintendo Switch games through an emulator (available in GURU overlay)" games-emulation/yuzu
+ optfeature "playing DOOM games" games-fps/gzdoom
+
+ # Quote README.rst
+ elog
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index a9e06207f6d4..765674cdc319 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -143,6 +143,7 @@ pkg_postinst() {
# TODO: Package TIC-80 tiny computer
optfeature "playing Commodore games through an emulator" app-emulation/vice
# TODO: Package Atari Jaguar emulator
+ # TODO: Package Vita3K PS Vita emulator
# TODO: Package runner for HTML5 web games
# TODO: Package Xbox emulator
optfeature "playing Nintendo Switch games through an emulator (available in GURU overlay)" games-emulation/yuzu