summaryrefslogtreecommitdiff
path: root/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-3.0.1-optional.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-3.0.1-optional.patch')
-rw-r--r--gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-3.0.1-optional.patch84
1 files changed, 84 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-3.0.1-optional.patch b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-3.0.1-optional.patch
new file mode 100644
index 000000000000..c12d7636f967
--- /dev/null
+++ b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-3.0.1-optional.patch
@@ -0,0 +1,84 @@
+--- a/configure.ac~ 2016-05-10 17:30:40.000000000 +0200
++++ b/configure.ac 2016-06-25 17:43:46.554279197 +0200
+@@ -259,14 +259,28 @@
+ dnl - color
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 0.1.27 cinnamon-desktop >= $CINNAMON_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AC_ARG_ENABLE(color,
++ AS_HELP_STRING([--disable-color], [disable Colord support (default: enabled)]),,
++ enable_color=yes)
++build_color=false
++if test x"$enable_color" != x"no" ; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.27 cinnamon-desktop >= $CINNAMON_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ build_color=true
++fi
++
++AM_CONDITIONAL(BUILD_COLOR, [test "x$build_color" = "xtrue"])
+
+ dnl ---------------------------------------------------------------------------
+ dnl - wacom
+ dnl ---------------------------------------------------------------------------
++AC_ARG_ENABLE(wacom,
++ AS_HELP_STRING([--disable-wacom], [disable Wacom support (default: auto)]),,
++ enable_wacom=auto)
+ build_wacom=false
+-PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 cinnamon-desktop xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION gtk+-3.0 >= 3.8.0],
+- [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
++if test x"$enable_wacom" != x"no" ; then
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 cinnamon-desktop xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION gtk+-3.0 >= 3.8.0],
++ [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
++fi
+
+ AM_CONDITIONAL(BUILD_WACOM, test "x$build_wacom" = "xtrue")
+
+@@ -372,9 +386,15 @@
+ dnl Check for logind
+ dnl ====================================================================
+
+-PKG_CHECK_MODULES(LOGIND, [libsystemd-login], [have_logind=yes], [
+- PKG_CHECK_MODULES(LOGIND, [libsystemd], [have_logind=yes], [have_logind=no])
+-])
++AC_ARG_ENABLE([logind],
++ AS_HELP_STRING([--disable-logind], [Do not check for logind]),
++ [enable_logind=$enableval],
++ [enable_logind=auto])
++
++have_logind=no
++if test x$enable_logind != xno ; then
++ PKG_CHECK_MODULES(LOGIND, [libsystemd-login], [have_logind=yes], [have_logind=no])
++fi
+
+ if test x$have_logind = xyes; then
+ AC_DEFINE(HAVE_LOGIND, 1, [Define if logind is supported])
+@@ -595,6 +615,7 @@
+ LCMS DICT support: ${have_new_lcms}
+ Libnotify support: ${have_libnotify}
+
++ Colord support: ${build_color}
+ Wacom support: ${build_wacom}
+
+ Smartcard support: ${have_smartcard_support}
+--- a/plugins/Makefile.am~ 2016-05-10 17:30:40.000000000 +0200
++++ b/plugins/Makefile.am 2016-06-25 17:44:30.021307677 +0200
+@@ -6,7 +6,6 @@
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ dummy \
+ datetime \
+@@ -23,6 +22,12 @@
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if BUILD_WACOM
+ enabled_plugins += wacom
+ else