summaryrefslogtreecommitdiff
path: root/gnome-extra/cjs
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest3
-rw-r--r--gnome-extra/cjs/cjs-5.8.0.ebuild95
-rw-r--r--gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch38
3 files changed, 136 insertions, 0 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index d1122d40c2f2..a3aa420a9255 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,4 +1,7 @@
AUX cjs-5.6.1-clang15.patch 1712 BLAKE2B b3e78b3e13f34011e45b13f537860cb18329b5e5249d83f987b0803e8429bd4ebf7434d0788d7cdd458bd44e83538eacbd7c491cdbc10e663b07c17eb90f6612 SHA512 b731d86a8f76afe66dae5b49747374947e63437b40e0bccc5654bc28f00b1ea52cb14db734803c1f172bc91cc85fe0683260793407b8e0e6f482d6edd8ee0280
+AUX cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch 1417 BLAKE2B 203701b5535b338283b99aad63e3577d3abb295c005d2e2ac908e2f8abdb24e8f7b9ef311bcf35889a93804583f13ac65f1d9453111b5195320aab9442237b2e SHA512 e2f7ed4c5f15cec6a6a7d3303779a217716ca3d8fa5d3128f4e7e685c47284fd95b9e416d50b28ca34bd06a9c469ebb3f317db88526cdc2ba1088381871da9a4
DIST cjs-5.6.1.tar.gz 794907 BLAKE2B 9ec6d5ffb33a28dca96d640da7b499e81751d5889dd0caec354fdf41de7b42c8d8edd737def68c2506c94af7a69a4d3433c459da2a5884f2668f14eac22163a0 SHA512 35662d78174d428610642198d7777a2c19137cd61dce93de69011fea235b0f461a2072ff219da0f18ef36068c1e3e5c2dc88684493b900a12fc1cd0b32503ae5
+DIST cjs-5.8.0.tar.gz 877668 BLAKE2B e4c031631030c2a4221937d5ca04034163f70f21e6e5ff2d0ca15f31a7455e83ecb1f977c4c4fb9a57e58d266856f817446e53b86ee87460bedf5339e33461b6 SHA512 f43bda5810b90ceab24d096d884c65503b2d9b94f5c0a9e6082215a427df97fbec4a21ee3f2d4f22d98ac24a04af1dcd9064600ec191ccec96ae0869cc803a02
EBUILD cjs-5.6.1.ebuild 2341 BLAKE2B 4e70e52c2aa8cdc54490a73493587ffe9be727cf7b03c06324d4f975e00879d3e415e0d79a7c5db645b7d086cedffce35d1bc0884b172b4c7a72ffb727c644f7 SHA512 a4969fdc1da52051a9a7aa6c49e7b579e091f08c4c84e5d4c0cd596478e242981045c054eb3a3380c59df254616d912ed4d6c67820fcf616ff49bcf19e3938f2
+EBUILD cjs-5.8.0.ebuild 2388 BLAKE2B 74f6dc7bae94a7819a9847a15e9fa84acc810d959b5e6e6e09a625fefa963b6b6906ca4cb3f6966e3306334b6ab95a27969653343b1021cc58bce86d86ee166a SHA512 9f6f958c0906fe517c8165463c87d764ba0a382e4025746a44426616990a02f12b31ca727901f3ea660d7953631b090ddbd891aa97aaba6d5df2f45c8f8542d9
MISC metadata.xml 608 BLAKE2B 7cc55145357fc7b4b46e1a77f19570b60f5dc6207c81efc3b92adf7d5fdb025296d4e6b8b927f193ed7bd0a929274e61c9bdddad2371ca78a497b94fdbe87737 SHA512 672923005e936fd3d08367a8db65318f63217841e6f841623d469c21ce354724f6c2cea853ecca928280b21011d6aa0e133a7830841c9fa44dd8c36402b28066
diff --git a/gnome-extra/cjs/cjs-5.8.0.ebuild b/gnome-extra/cjs/cjs-5.8.0.ebuild
new file mode 100644
index 000000000000..4a0965dcd743
--- /dev/null
+++ b/gnome-extra/cjs/cjs-5.8.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit flag-o-matic meson pax-utils python-any-r1 virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-lang/spidermonkey:102
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gobject-introspection-1.71.0:=
+ >=dev-libs/libffi-3.3:0=
+
+ cairo? (
+ x11-libs/cairo[glib,svg(+),X]
+ x11-libs/libX11
+ )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
+)
+
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}
diff --git a/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch b/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
new file mode 100644
index 000000000000..2bb80126507f
--- /dev/null
+++ b/gnome-extra/cjs/files/cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch
@@ -0,0 +1,38 @@
+# https://gitlab.gnome.org/GNOME/gjs/-/issues/532
+# https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/830/diffs?commit_id=83683d093c157828cf7787e53a32c586ae4e85d3
+diff --git a/installed-tests/js/meson.build b/installed-tests/js/meson.build
+index 6db887d2250face397079b03d215bbd13f455efb..1e953ceb7695356b6e854775e5db005a9c22e053 100644
+--- a/installed-tests/js/meson.build
++++ b/installed-tests/js/meson.build
+@@ -203,9 +203,13 @@ endif
+ # during build should be run using dbus-run-session
+
+ dbus_tests = ['GDBus']
+-if have_gtk4 and not get_option('skip_gtk_tests')
+- # FIXME: find out why GTK4 tries to acquire a message bus
+- dbus_tests += 'Gtk4'
++if not get_option('skip_gtk_tests')
++ have_gtk4 = dependency('gtk4', required: false).found()
++
++ if have_gtk4
++ # FIXME: find out why GTK4 tries to acquire a message bus
++ dbus_tests += 'Gtk4'
++ endif
+ endif
+
+ bus_config = files('../../test/test-bus.conf')
+diff --git a/meson.build b/meson.build
+index 3ac372a16b0bfaa364ed7422119f3e6e4af8971e..5c7703935b68c724347692ef5bf47a3edf868c61 100644
+--- a/meson.build
++++ b/meson.build
+@@ -679,10 +679,6 @@ endif
+
+ ### Tests and test setups ######################################################
+
+-if not get_option('skip_gtk_tests')
+- have_gtk4 = dependency('gtk4', required: false).found()
+-endif
+-
+ subdir('installed-tests')
+
+ # Note: The test program in test/ needs to be ported