summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild
deleted file mode 100644
index 7e7757ece5a3..000000000000
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-12.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit gnome2-utils
-
-# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
-DESCRIPTION="Show tooltip with full name and description"
-HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
-SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
- app-eselect/eselect-gnome-shell-extensions
- >=gnome-base/gnome-shell-40
-"
-DEPEND=""
-BDEPEND=""
-
-S="${WORKDIR}/${P/gnome-shell-extension-}"
-extension_uuid="applications-overview-tooltip@RaphaelRochet"
-
-src_install() {
- einstalldocs
- insinto /usr/share/glib-2.0/schemas
- doins schemas/*.xml
- rm -rf README.md schemas || die
- insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
- doins -r *
-}
-
-pkg_preinst() {
- gnome2_schemas_savelist
-}
-
-pkg_postinst() {
- gnome2_schemas_update
- ebegin "Updating list of installed extensions"
- eselect gnome-shell-extensions update
- eend $?
-}
-
-pkg_postrm() {
- gnome2_schemas_update
-}