summaryrefslogtreecommitdiff
path: root/gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild')
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild
new file mode 100644
index 000000000000..9063308be5d3
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.17_pre20240924.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+HASH_EGLWAYLAND=c10c5300483a8ec975e64e5d76c0fb00ac94e026
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/${HASH_EGLWAYLAND}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-${HASH_EGLWAYLAND}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)