summaryrefslogtreecommitdiff
path: root/gui-libs
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/Manifest.gzbin4285 -> 4280 bytes
-rw-r--r--gui-libs/gtk/Manifest4
-rw-r--r--gui-libs/gtk/gtk-4.10.0.ebuild215
-rw-r--r--gui-libs/gtk/metadata.xml1
-rw-r--r--gui-libs/libadwaita/Manifest2
-rw-r--r--gui-libs/libadwaita/libadwaita-1.2.3.ebuild66
-rw-r--r--gui-libs/libhandy/Manifest2
-rw-r--r--gui-libs/libhandy/libhandy-1.8.2.ebuild61
-rw-r--r--gui-libs/wpebackend-fdo/Manifest2
-rw-r--r--gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild35
10 files changed, 387 insertions, 1 deletions
diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index 0efbab9482ee..e460c0db0f81 100644
--- a/gui-libs/Manifest.gz
+++ b/gui-libs/Manifest.gz
Binary files differ
diff --git a/gui-libs/gtk/Manifest b/gui-libs/gtk/Manifest
index 4288125023f7..7007194bafe1 100644
--- a/gui-libs/gtk/Manifest
+++ b/gui-libs/gtk/Manifest
@@ -1,3 +1,5 @@
+DIST gtk-4.10.0.tar.xz 20471568 BLAKE2B 8fed349e7854a7845232da556b2949bc4eaf5d3aaface86c6e2c3a505aefeb754e3147c7a10f82e0fee713418bc8d78186942e98d59a42ed7288d48d88e52f28 SHA512 1283985ed64035e3b183cccc341dd38029112e8277065f8b39be56b4f489aaf03efc0ce5f9c36ddd746a776be3772f7606f1c54fd84292479d63d86b94281159
DIST gtk-4.8.3.tar.xz 20297060 BLAKE2B ad0f9e2998f3748afe4a03317e6d0438bfd9eaf804f202e96724541cce20597b7b6e69d5c50ce319450feed4f4a5653c0d99b949b23ce3a40c46a12da7e2d85f SHA512 56be0f5ce85a9cbbda4a5de53baeeb6b8cc527a5d34723ae5548759ec7c28f03d204b6b6758dffed02a9e226f3bfcd1f15971105c2f2f7be7cef22538be27754
+EBUILD gtk-4.10.0.ebuild 5753 BLAKE2B fca451f2e97bbbacd8350b5bf3811d9e1269f59386941dbd9d902c55803cb2c7cba35be51102cdcc087434a4afed966cddd8e0d8daeecef989681a17e860c136 SHA512 c3dad76cee78f2b612df2d4ff493a00b209ba87e3db7ac7477b017f950ca9dad859f1a4004c4fad0bee58551afa51155e74148d5a1f0ae50e2721124591aa2da
EBUILD gtk-4.8.3.ebuild 5697 BLAKE2B 7922fe293e49c01fa1d561c46805f3e3d41fa1891ce2d445cacfa85f059416986f3ce12c75736087c0dde47d001b71d5ab110a2d4615b91a4a3d1478e3f653b2 SHA512 9e9a9fc842dc89af1931b8a0c00ed6e6a065d4aa9b9525baa56fdea56747919386092846eb35a299e68d47af0f1f885f20ec16afb13685e6855fcbe7649cf551
-MISC metadata.xml 761 BLAKE2B 9bfb7757b82761ef2285e2d912376112958df4400ed93bdfc4a3f195cada9caf927cbced29820f6db049b8e5b7f2246d9264290ade62ba3bde8975491fd6331b SHA512 6ba84b2e3eeafceb179339561ac5e9fbd94dc34b71da768d9ca909818cf0c9ec5fe04906ed33aa58bc56929323bc41272223faee908052861fd1c6f8bbad95a5
+MISC metadata.xml 849 BLAKE2B 729466a39564aa6c7dfc1768319061645d6b46297d653eb79092fcd4f1319e74e87723d1bca1ca5cde1490d47bb4984abe0407d555a9fb84bd2fdf83f41ad9af SHA512 3f8f67936202a7daa7dd9015bc2569930b70f9944cff7821f7d99376660c873537ab64e1c81189c0ccaab7a48d392da715b456a9dd3937dd7b045b8491cb820e
diff --git a/gui-libs/gtk/gtk-4.10.0.ebuild b/gui-libs/gtk/gtk-4.10.0.ebuild
new file mode 100644
index 000000000000..162cca71d230
--- /dev/null
+++ b/gui-libs/gtk/gtk-4.10.0.ebuild
@@ -0,0 +1,215 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome.org gnome2-utils meson optfeature python-any-r1 virtualx xdg
+
+DESCRIPTION="GTK is a multi-platform toolkit for creating graphical user interfaces"
+HOMEPAGE="https://www.gtk.org/ https://gitlab.gnome.org/GNOME/gtk/"
+
+LICENSE="LGPL-2+"
+SLOT="4"
+IUSE="aqua broadway cloudproviders colord cups examples ffmpeg gstreamer +introspection sysprof test vulkan wayland +X cpu_flags_x86_f16c"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ test? ( introspection )
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.72.0:2
+ >=x11-libs/cairo-1.17.6[aqua?,glib,svg(+),X?]
+ >=x11-libs/pango-1.50.0[introspection?]
+ >=dev-libs/fribidi-1.0.6
+ >=media-libs/harfbuzz-2.6.0:=
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?]
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libjpeg-turbo:=
+ >=media-libs/libepoxy-1.4[egl,X(+)?]
+ >=media-libs/graphene-1.10.0[introspection?]
+ app-text/iso-codes
+ x11-misc/shared-mime-info
+
+ cloudproviders? ( net-libs/libcloudproviders )
+ colord? ( >=x11-misc/colord-0.1.9:0= )
+ cups? ( >=net-print/cups-2.0 )
+ ffmpeg? ( media-video/ffmpeg:= )
+ gstreamer? (
+ >=media-libs/gst-plugins-bad-1.12.3:1.0
+ >=media-libs/gst-plugins-base-1.12.3:1.0[opengl]
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.72:= )
+ vulkan? ( media-libs/vulkan-loader:= )
+ wayland? (
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.25
+ media-libs/mesa[wayland]
+ >=x11-libs/libxkbcommon-0.2
+ )
+ X? (
+ >=app-accessibility/at-spi2-core-2.46.0
+ media-libs/fontconfig
+ media-libs/mesa[X(+)]
+ x11-libs/libX11
+ >=x11-libs/libXi-1.8
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.5
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ X? ( x11-base/xorg-proto )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ gnome-base/librsvg
+ >=x11-themes/adwaita-icon-theme-3.14
+"
+BDEPEND="
+ dev-libs/gobject-introspection-common
+ introspection? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ )
+ dev-python/docutils
+ >=dev-util/gdbus-codegen-2.48
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+ test? (
+ dev-libs/glib:2
+ media-fonts/cantarell
+ wayland? ( dev-libs/weston[headless] )
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+}
+
+pkg_setup() {
+ use introspection && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # Nothing should use gtk4-update-icon-cache and an unversioned one is shipped by dev-util/gtk-update-icon-cache
+ sed -i -e '/gtk4-update-icon-cache/d' tools/meson.build || die
+ # Workaround RWX ELF sections, https://gitlab.gnome.org/GNOME/gtk/-/issues/4598
+ sed -i -e 's/^ld =.*/ld = disabler()/g' gtk/meson.build demos/gtk-demo/meson.build demos/widget-factory/meson.build || die
+ sed -i -e 's/^objcopy =.*/objcopy = disabler()/g' gtk/meson.build demos/gtk-demo/meson.build demos/widget-factory/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ # GDK backends
+ $(meson_use X x11-backend)
+ $(meson_use wayland wayland-backend)
+ $(meson_use broadway broadway-backend)
+ -Dwin32-backend=false
+ $(meson_use aqua macos-backend)
+
+ # Media backends
+ $(meson_feature ffmpeg media-ffmpeg)
+ $(meson_feature gstreamer media-gstreamer)
+
+ # Print backends
+ -Dprint-cpdb=disabled
+ $(meson_feature cups print-cups)
+
+ # Optional dependencies
+ $(meson_feature vulkan)
+ $(meson_feature cloudproviders)
+ $(meson_feature sysprof)
+ -Dtracker=disabled # tracker3 is not packaged in Gentoo yet
+ $(meson_feature colord)
+ # Expected to fail with GCC < 11
+ # See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71993
+ $(meson_feature cpu_flags_x86_f16c f16c)
+
+ # Documentation and introspection
+ -Dgtk_doc=false # we ship pregenerated API docs from tarball
+ -Dupdate_screenshots=false
+ -Dman-pages=true
+ $(meson_feature introspection)
+
+ # Demos and binaries
+ $(meson_use test build-testsuite)
+ $(meson_use examples build-examples)
+ $(meson_use examples demos)
+ -Dbuild-tests=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+
+ if use X; then
+ einfo "Running tests under X"
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx meson_src_test --setup=x11
+ fi
+
+ if use wayland; then
+ einfo "Running tests under Weston"
+
+ export XDG_RUNTIME_DIR="$(mktemp -p $(pwd) -d xdg-runtime-XXXXXX)"
+
+ weston --backend=headless-backend.so --socket=wayland-5 --idle-time=0 &
+ compositor=$!
+ export WAYLAND_DISPLAY=wayland-5
+
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" meson_src_test --setup=wayland
+
+ exit_code=$?
+ kill ${compositor}
+ fi
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/gtk-doc/html
+ # This will install API docs specific to X11 and wayland regardless of USE flags, but this is intentional
+ doins -r "${S}"/docs/reference/{gtk/gtk4,gsk/gsk4,gdk/gdk4{,-wayland,-x11}}
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+
+ if use examples ; then
+ optfeature "syntax highlighting in gtk4-demo" app-text/highlight
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gui-libs/gtk/metadata.xml b/gui-libs/gtk/metadata.xml
index ba004a3523be..738bf162e983 100644
--- a/gui-libs/gtk/metadata.xml
+++ b/gui-libs/gtk/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="broadway">Enable the GDK Broadway backend.</flag>
+ <flag name="cloudproviders">Enable GtkPlacesSidebar to access cloud services</flag>
<flag name="colord">Use <pkg>x11-misc/colord</pkg> for color management in printing</flag>
<flag name="sysprof">Enable profiling data capture support using <pkg>dev-util/sysprof-capture</pkg></flag>
<flag name="vulkan">Enable support for the Vulkan graphics API</flag>
diff --git a/gui-libs/libadwaita/Manifest b/gui-libs/libadwaita/Manifest
index c3ed98b54608..e6955fffa5ee 100644
--- a/gui-libs/libadwaita/Manifest
+++ b/gui-libs/libadwaita/Manifest
@@ -1,5 +1,7 @@
DIST libadwaita-1.2.1.tar.xz 2023892 BLAKE2B 1adb99f360cded03450575206d23d9d9a6e50b2e7afc3b58a7ecee2b35b09896ab03a584a8f21fca0ea95109d3dd4df46269428934bf7563b716aaaa117fc85c SHA512 e7de0a5bcd01cbabf5a25fe5b81ba2488b0a33bfaa78e3aa12b64d6373b7ffe958ef7d7b438633edf38dff52d58efbff0365c9d7c191fc895ec7daf62eff1605
DIST libadwaita-1.2.2.tar.xz 1938256 BLAKE2B 4ef46d1781e73d18edea75f663d29c6b8570e40f3d0d8987626104e3a49d39f0ca348ae215a8d572acf062a6320750df055efbd70a63ef1403d79e6d70e2b5f6 SHA512 65bf576145a4cae199dd927b27c295a72b6615d549186ec216a8aae3337ebd3d2b102eca75133a4211c4d2841e32d4e4d510bce72c3424eee1e2d4603b5642e1
+DIST libadwaita-1.2.3.tar.xz 2950664 BLAKE2B 8c76554d603992e99240782a2b52245d5f2149d4eca01a79828bf321545bd249d7742246372d09d7351584b48762f1ba3eac8aa3a391ce658f0025a2ebb1cbce SHA512 dd8eb41df7f8b0f71c711c6d1f350b147e52e37f8d0e5df2a7264c6bdff43b8b0a787c243432039ca1c991f22b109229515c4bc8a10a29ff4c93f1b53813c8ad
EBUILD libadwaita-1.2.1.ebuild 1487 BLAKE2B dab9b1cec346f1b20f34ed1347479a58f9142cdbe534c1f2e32ef38d35d92c2760bc38816bb93597481096016410adbc1f7e40733c08a1721b191da36b09f596 SHA512 414540cd74d85c9163636932801cf5d229c0feccb8544ae0e684cfadb432a4036411252a19114160aececf66c4a4534dd6f85b571750d8642c6462dc6ad7fea5
EBUILD libadwaita-1.2.2.ebuild 1492 BLAKE2B f8666af672936a976cf4233669b7654ea48b6f1472f5237400a5e8b032b1a2b0b9aa75e5fc13c662c2c6c640edd6ba5bf23d4c97a4fb2df23dbd282f53ae8da7 SHA512 6b5a64d0348d01bc91292be4d9adb7e0c424c9d51d9f540aa2132a3f7eef564b09a25a46ce0153f6434f668989c2946cbb1f7fd175902d1d3a42b4fdcf9b11d7
+EBUILD libadwaita-1.2.3.ebuild 1492 BLAKE2B f8666af672936a976cf4233669b7654ea48b6f1472f5237400a5e8b032b1a2b0b9aa75e5fc13c662c2c6c640edd6ba5bf23d4c97a4fb2df23dbd282f53ae8da7 SHA512 6b5a64d0348d01bc91292be4d9adb7e0c424c9d51d9f540aa2132a3f7eef564b09a25a46ce0153f6434f668989c2946cbb1f7fd175902d1d3a42b4fdcf9b11d7
MISC metadata.xml 351 BLAKE2B ae57c9eb56cb12bf754b28c2e6620c09ad7ccc79396fd0476e99e52b93bf6d3900fc84ab55fdf11d98e59ed9e247cabf6f301d45bc5e4c453c0fcffc49b144cb SHA512 dc1333518d24d60f69a180ee7369c4b783f234bda36cd65ec66d483db86f3123eca5ed10cd8aadc7a183b707d698a159d7917f7ebd1c342c212f15e90cb8d5df
diff --git a/gui-libs/libadwaita/libadwaita-1.2.3.ebuild b/gui-libs/libadwaita/libadwaita-1.2.3.ebuild
new file mode 100644
index 000000000000..11c36e9c0796
--- /dev/null
+++ b/gui-libs/libadwaita/libadwaita-1.2.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome.org meson python-any-r1 vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME applications"
+HOMEPAGE="https://gnome.pages.gitlab.gnome.org/libadwaita/ https://gitlab.gnome.org/GNOME/libadwaita"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+IUSE="+introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.66:2
+ >=gui-libs/gtk-4.5.0:4[introspection?]
+ dev-libs/fribidi
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/appstream-glib )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ vala? ( $(vala_depend) )
+ >=dev-util/meson-0.59.0
+ dev-util/glib-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dprofiling=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_use test tests)
+ -Dexamples=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test --timeout-multiplier 2
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/gtk-doc/html
+ # This will install libadwaita API docs unconditionally, but this is intentional
+ doins -r "${S}"/doc/libadwaita-1
+}
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index 463dc13ea2cd..6da982126896 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1,5 +1,7 @@
DIST libhandy-1.8.0.tar.xz 1796032 BLAKE2B 15929cfde5e01b25e0ccc4dfa94bb0d12272b02a5c5196fcb3a85a898bf8384faa4101114e14f44d53f326fa5321254bba85e3c7f41e426ebd116e2d3dfd96ca SHA512 88f37d310ddc26a26612648d9f7beff6e77347a2cf59f682690dc838c3ec1bad9408ed39571c6cd779bea3d334a9c275ba3789d45c11c0a3e454617d41cc0035
DIST libhandy-1.8.1.tar.xz 1801348 BLAKE2B 48d9f37f333bbebacd265a802c8fad6aa4c5a2c5ffaa879ee61fd02c92e10b9c60bd01f6bff0afe4573b6e8e3b16fc4633b25c98e5c7e0adb787161ee1aeee88 SHA512 ffcc8dfc0687e3410d1c1b10b56a974925688eee4a971baffc9adafc3585e5e3f4e91b04c6ab1aea99b1d582982a28bdc13c07cdf2af523e1af0d724229b4999
+DIST libhandy-1.8.2.tar.xz 1778096 BLAKE2B 83b8316b22e7bd37436d5fdad0bd270dd5d64862bca97d358b0c2a1c6b7b0e18e0f472ce453719dfde982a427fd7c0c523b042d7721415602d3e7b9c57399509 SHA512 ec48c66a95b1e9158d3e072e1cfab6d538a9235966c790f1e4d4f2ec40a251c8818f505d031285a53ce855da92b7919d3a26aca4160d93241925da1e8cf4b748
EBUILD libhandy-1.8.0.ebuild 1310 BLAKE2B 49bf62afa3ef7679b9cfa9a60b5254e1d07a24ad6cbec63f8e9dfb398f2782d530bf32c0b2ddb1d8cece613c2547ec22ebd8785fd140c4e08cbe06413aa09c9e SHA512 6a9720e795763215c4e3157049fdc53c1e5e3ef6df24f4da1e175a4e6d4fad8f563dcac41b9e11d1819604161c8cde7c3faf917d697a6585eaa5f0aaf196cea5
EBUILD libhandy-1.8.1.ebuild 1336 BLAKE2B 4e928c5ce7317fdd2a90b14b526d1058b4e36e50366612099b03cade06ecdcb809d897807dbf20b8df4fddd6e5676a73acb7aa59280e7e095c7bb4bc2b445e23 SHA512 0742808cb9fe658db92c262702db606ba711e8fd84e2fea7aa412e47dd0dd13b650ebb2512fea9cef502db672cfc887c01f805469552dfe79dbf041f659a3e3e
+EBUILD libhandy-1.8.2.ebuild 1336 BLAKE2B 4e928c5ce7317fdd2a90b14b526d1058b4e36e50366612099b03cade06ecdcb809d897807dbf20b8df4fddd6e5676a73acb7aa59280e7e095c7bb4bc2b445e23 SHA512 0742808cb9fe658db92c262702db606ba711e8fd84e2fea7aa412e47dd0dd13b650ebb2512fea9cef502db672cfc887c01f805469552dfe79dbf041f659a3e3e
MISC metadata.xml 453 BLAKE2B 3b7a719256d86a2cb3411691777d24bb9638760fc17312e299b9895c8a75e088a438db4a16cd81846564b655ea27bdd1f27b3220571b71a264e5171f22ebdac7 SHA512 8d2ffbe79d880deef5f132e3a10ecfa4a044553a075a63904b4938b15bb47104d2ea731bdc5472bfcb816c4fcca83453b81ec1b3dff29f3ce0968a79d22c5106
diff --git a/gui-libs/libhandy/libhandy-1.8.2.ebuild b/gui-libs/libhandy/libhandy-1.8.2.ebuild
new file mode 100644
index 000000000000..1a9f78259e46
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.8.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
diff --git a/gui-libs/wpebackend-fdo/Manifest b/gui-libs/wpebackend-fdo/Manifest
index dd866e9b0a56..dc424f52a121 100644
--- a/gui-libs/wpebackend-fdo/Manifest
+++ b/gui-libs/wpebackend-fdo/Manifest
@@ -1,3 +1,5 @@
DIST wpebackend-fdo-1.14.0.tar.xz 43068 BLAKE2B e5b06e7313a0122578fd668cb17a0f28e8f67ba4831b80616979ebedf15ee4fde94f610b5c7e4831ce90c51e11573ff8fc8f4970237230f5d3184b8aead21ce6 SHA512 9eda873adda854e1e498236215b7e240076caca52adca4f60277fb26db8ae9e6436b27a9b25ebf95612835acad82b764ccd21d8ae997e8802665dd79251083d6
+DIST wpebackend-fdo-1.14.1.tar.xz 43188 BLAKE2B e4e2ae5da7ca93847644e5f6cbb97251f394ab6237b59868e727e89ea57f8676c8319a7a944a4b5080161187d6b5c6937af3913976f215ceb99b42b5fe86c5c0 SHA512 711ffa968852818f080dbb2b222168b61d0d20584b6022e309be7f1a06128440c91d30e61673a30f89831aba4b30dbc0cdae560b3d5f6c8ac462b5445a4c9e8b
EBUILD wpebackend-fdo-1.14.0.ebuild 667 BLAKE2B 6ffcfbb980921cc47cdda79aa761113ed744738f8f753abaf232d3505b8ab51d028b20a51e6abc114f4bc84447ef6ca9a87ec1441c815d5069588327f71f9e39 SHA512 3817365bb335d63365aba4ef2b7464b70783a53d5b0d341af3ff2df8604922dda845389af4e37cd9ceda101ffb2e353f01ffe25cc345c5b7b29977205170f72d
+EBUILD wpebackend-fdo-1.14.1.ebuild 673 BLAKE2B 83c96677335dcc62778414b3036e66a8feb2a0f77a89e5932214d6943bd0321017593db46fc0955e7648e3cd7ffcf28d2fb6b03789458f70cb7e6cf5e26ece71 SHA512 298b5fd72f5e13e61810ca6f2b589d68cf9252f6829682f4ce945fe8cb06ec19a24181b35a14101d2e8c123dffcefbb9c91fbd65b8717c471d6d902b48eaac06
MISC metadata.xml 350 BLAKE2B df50880a0744703272cd3aecfb9dae45d62e4233a0c5b3e1fdc06b1d05f814bd57c8b1a4b20cd88a97bc2c22a22bd84befd15c9c3ab094aeeae97346d8713ed0 SHA512 a1bdbe1182fd4545bd83a55d589dd17dce2b306510763f2305e7e43dba6c28c7c5cb85628ccc7eb3ce763b694f0b1b172b19d5aa72ad4c686e600d6ba4ebe765
diff --git a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild
new file mode 100644
index 000000000000..a831404745c4
--- /dev/null
+++ b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="WPE backend designed for Linux desktop systems"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/libepoxy[egl]
+ dev-libs/glib:2
+ >=dev-libs/wayland-1.10
+ >=gui-libs/libwpe-1.6:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_docs=false # hotdoc not packaged
+ )
+
+ meson_src_configure
+}