summaryrefslogtreecommitdiff
path: root/kde-apps/korganizer/korganizer-4.4.2017.04.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/korganizer/korganizer-4.4.2017.04.ebuild')
-rw-r--r--kde-apps/korganizer/korganizer-4.4.2017.04.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/kde-apps/korganizer/korganizer-4.4.2017.04.ebuild b/kde-apps/korganizer/korganizer-4.4.2017.04.ebuild
new file mode 100644
index 000000000000..ec9f212bf2fc
--- /dev/null
+++ b/kde-apps/korganizer/korganizer-4.4.2017.04.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+QT3SUPPORT_REQUIRED="true"
+inherit kde4-meta
+
+DESCRIPTION="Personal Organizer by KDE (noakonadi branch)"
+HOMEPAGE="https://launchpad.net/~pali/+archive/ubuntu/kdepim-noakonadi"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs '' 4.14.10_p20160611)
+ $(add_kdeapps_dep libkdepim)
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}
+ !>kde-apps/kdepimlibs-4.14.11_pre20160211
+ $(add_kdeapps_dep ktimezoned '' 4.14.3)
+"
+
+KMLOADLIBS="libkdepim"
+KMEXTRA="kdgantt1"
+
+# xml targets from kmail are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ kmail/
+ knode/org.kde.knode.xml
+ kaddressbook/org.kde.KAddressbook.Core.xml
+"
+
+# bug 378151
+RESTRICT=test
+
+src_unpack() {
+ if use kontact; then
+ KMEXTRA="${KMEXTRA}
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-apps/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-apps/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}