summaryrefslogtreecommitdiff
path: root/kde-misc/plasma-pass
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/plasma-pass')
-rw-r--r--kde-misc/plasma-pass/Manifest3
-rw-r--r--kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch29
-rw-r--r--kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild2
3 files changed, 33 insertions, 1 deletions
diff --git a/kde-misc/plasma-pass/Manifest b/kde-misc/plasma-pass/Manifest
index 63da362b675f..7a4323c4624a 100644
--- a/kde-misc/plasma-pass/Manifest
+++ b/kde-misc/plasma-pass/Manifest
@@ -1,3 +1,4 @@
+AUX plasma-pass-1.1.0-qt-5.15.patch 1008 BLAKE2B 345d71a8ec910dcc8130bbd53f607760db4ea443bd2dae34fcbef81fd008f870894f3e2c7f5b723cb342fc2f77d7b6644a16fe800d8d58aa188295f8f426feb9 SHA512 261dd6d62e7fec9d046190569704dcf47cb0cdc32ef40c1bab7ebfa0b5d10f7a81abac5c1af0606082dabf3afb183c73d7e5da8abe1f29492f422a90a51e2a33
DIST plasma-pass-1.1.0.tar.xz 28204 BLAKE2B 69aa9d8f5ece8625c0d371ebfb565b2ce60e0a0fa73458ab30eaa9acf1858f0d9b2e30532d7a56dc821533964f09d9b6fced2b965d5fc9b5c1728e1b79f9a2c6 SHA512 402a19d44028117878214140c4eff74f25775aea6492fd751883e56bfe8ae08b330bb93f0a271c55f942f8ce1ee3de00cb6ad1b7fd4629beb59e898650b8166d
-EBUILD plasma-pass-1.1.0.ebuild 826 BLAKE2B 5429803935dd88deed802096ca2c56cac533ca7ee635a770e4d06630d2f01b125887708bb9897c590803da09d52048393ea27e1df8279d8d47ce983fb26795e2 SHA512 caa0de0106dab2292f01b7b2f58ea43b95cbe7d001c9d038d6ccaf8700c9c8e3130d05b478e52d86a79f97d2f87d0ca65253ad198d2a9ffbfff60392a1c9c136
+EBUILD plasma-pass-1.1.0.ebuild 872 BLAKE2B 018ae56aa96f51bd3df9d6b6e3ea7233eb6f94233167407d39defe207124e37d1e43c24ef07244b1e910704e83020d1c64ede0fd377b88dd74de614cb2d88879 SHA512 92ac8fe1b46ce626d4212d4ffdb8ff88fc09027d9b2b36d71c18803c79b5c001bd59ec119444751ca41f95904d652c22434a8560be088abf3a89b5263124a1f9
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch b/kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch
new file mode 100644
index 000000000000..ea67cf18dd21
--- /dev/null
+++ b/kde-misc/plasma-pass/files/plasma-pass-1.1.0-qt-5.15.patch
@@ -0,0 +1,29 @@
+From 3fb633159ca4a1db166d5c54bbc025f71aba1652 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
+Date: Thu, 9 Apr 2020 12:48:53 +0200
+Subject: Fix build against Qt 5.15
+
+* asturm 2020-06-07: Rebased for 1.1.0
+
+---
+ plugin/passwordfiltermodel.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/plugin/passwordfiltermodel.cpp b/plugin/passwordfiltermodel.cpp
+index e815797..2d323ad 100644
+--- a/plugin/passwordfiltermodel.cpp 2019-12-06 07:59:15.000000000 +0100
++++ b/plugin/passwordfiltermodel.cpp 2020-06-07 11:22:23.310950571 +0200
+@@ -79,7 +79,11 @@
+ Q_ASSERT(sender() == &mUpdateTimer);
+
+ mFilter = mUpdateTimer.property(newFilterProperty).toString();
++#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
+ mParts = mFilter.splitRef(QLatin1Char('/'), QString::SkipEmptyParts);
++#else
++ mParts = mFilter.splitRef(QLatin1Char('/'), Qt::SkipEmptyParts);
++#endif
+ Q_EMIT passwordFilterChanged();
+ mSortingLookup.clear();
+ invalidate();
+--
+cgit v1.1
diff --git a/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild b/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild
index 39281fe41e45..8bc8f79a2cac 100644
--- a/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild
+++ b/kde-misc/plasma-pass/plasma-pass-1.1.0.ebuild
@@ -32,3 +32,5 @@ DEPEND="
RDEPEND="${DEPEND}
>=kde-frameworks/kirigami-${KFMIN}:5
"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.15.patch" )