summaryrefslogtreecommitdiff
path: root/kde-plasma/kinfocenter
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest2
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.3.0.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index aa89002fe85f..4444c575a552 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,5 +1,7 @@
AUX kcm-about-distrorc 108 BLAKE2B 9324829040a699d8858a739b228b14035f8a33d4cc5e19af30545a6eb9780808b3350ca12c82a44a1868c32acddd76dcdb4e7b25e5792694b55fbb38ed23db8a SHA512 72f1dcaa04bfe435e64c8e584914eb56a15b63f7c6086f5e025f0c497b4fd5b9592d54aafd335f55d303790af274c9cbfa29c6c7ff87875da648ee16d7717467
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-6.2.5.tar.xz 732392 BLAKE2B 13e583696bcebda5a26935b66619314fa723c60463e5350963acaa6982ce8315c82355c911ae32b8c6ca4ee4832f017cb009fbd5e3b5a36f9f4c95a914a146fa SHA512 dba69043aa09df314275b9cbc6b3aed858dd3bab62381b8fdf83f8aad167581a06ff44a14f9f4cdefb4e205b088065dbdefb7e0fb78fb30508314ed929f3c669
+DIST kinfocenter-6.3.0.tar.xz 747832 BLAKE2B c97bde4abf60920babde2ef709a6bdc60da43e2c9031acc47aba7741f38e2a4be5808e3c52ddd04978ce43caea51050b8e98a24e382d6493be5b66396343b23e SHA512 e7ae2dbc39f4cab18cb74448c7d378c046d59d9b42794dc63dcc6cf93f1f21e0fd5357bbe897a0bae2d2d965c5264433962263b4b38f8aa8a1366dc307b8252a
EBUILD kinfocenter-6.2.5.ebuild 2581 BLAKE2B 607463a251a5dee56d5a9b09c0f36efacdee8ff4c1e4c65d5873ccc08a3b3e7b33c93f8d21d2a3ac05ab3137e2263943ed6b4c113fb21e6ba67f0c82be6bda45 SHA512 ab5e60ad7ca658a0eb40e78b006335593ee5d6cf2da66e32e9f472d1e4c38441a96cbb6fc9f9a22f4a79e42f12cc013b1a7fa6f34d7ac969392db3ab5406efd0
+EBUILD kinfocenter-6.3.0.ebuild 2605 BLAKE2B 942fe4fb595f446a0b5003d8b10efd8a4e7a21ccda44a07b250c0e312ce0bed42980417871519a0a7042ed3f2208a725c42d2027ce4e3bab8d6d588eed8d7d96 SHA512 4e56eb4a0b9416d240c9a8561eeac87113a038d49751c3ac2e9a34af7084d438d309de8c62fde57c76a3759468f8d87ced0d18fd5e81a402c05594034f32bbe0
MISC metadata.xml 387 BLAKE2B f03ad4c31bb639282d7c79e13fe8e6a79979350e30c7894bd7d83d80ae30358743ba87e8d6356dcc4fe97a51b8859e8185b779e811a4548e38e4f78f1c27446f SHA512 85da5fc7415747c5eece521eb789eb164153637144b15dc900121320f38f9e7ce3b857c38e18401a9710a9818a81260a6b90b5cc55fb63a409aba8c35e3f082b
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.3.0.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.3.0.ebuild
new file mode 100644
index 000000000000..50c34b990918
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-6.3.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+KFMIN=6.10.0
+QTMIN=6.8.1
+inherit ecm plasma.kde.org optfeature xdg
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gles2-only=,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ gles2-only? ( >=media-libs/mesa-24.1.0_rc1[opengl] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ || (
+ >=dev-qt/qttools-${QTMIN}:6[qdbus]
+ dev-qt/qdbus:*
+ )
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-plasma/systemsettings-${KDE_CATV}:6
+"
+BDEPEND="
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ virtual/pkgconfig
+"
+
+CMAKE_SKIP_TESTS=(
+ # bug 816591
+ smbmountmodeltest
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature_header "Query network filesystem info:"
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature_header "Query firmware/hardware info:"
+ fi
+ optfeature "System DMI table readout" sys-apps/dmidecode
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ optfeature_header "Query GPU/graphics support info:"
+ fi
+ optfeature "OpenCL information module" dev-util/clinfo
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ fi
+ xdg_pkg_postinst
+}