summaryrefslogtreecommitdiff
path: root/kde-plasma/kwallet-pam
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest2
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index f032e50fabca..0d2fa9e9f93b 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,3 +1,5 @@
DIST kwallet-pam-5.16.5.tar.xz 19512 BLAKE2B dc053b8b02d44a3b94fe16d50b03bf91718392bdce60e69b956e5a84406012b567f4216b08b4d05c215cfa0e9e16c7537b60420a80bf501402a7cf302b853d9b SHA512 6a3c09b645a193bd5164525c6ca0c807a0adc141566db7436101784fef8def79e121c599a837dac32393f8e5ab2c33a9473a29013d07bd64e6a8eab32308d3d1
+DIST kwallet-pam-5.17.2.tar.xz 19712 BLAKE2B 24da5b28399a9e7a98c5ea9077e019610075b7df3934651e1f3237fcd514ae76eab7f7a7a00080529d410b0eb9b2acb53481ad92668691b1099c66c5d17245b3 SHA512 5f3d8408488f6ae1e9b8f1a2e1975ccad3b8ca6bd9ff9a721f7ff83f50259d7a459a66bd48963702669c3751abe467917e0a7ebed5a05ed789a504c5ced29ffc
EBUILD kwallet-pam-5.16.5.ebuild 657 BLAKE2B 3e7808f3098d000d8ab4670dccc6a3c15e6bdbea4c4201dc5e95ecdc9d9785fa5af4c721e3976f31987e0f074233dcb874aa461174101da3be7a8ee0e3c26680 SHA512 a1a06693a8ceb902aa8652ec95624b7c8850cc60731b43e71b61d4655399db7a25934c7c5be809cf395dc5c810c1ce13cef2212968d7d38248a0cf8dd8733341
+EBUILD kwallet-pam-5.17.2.ebuild 660 BLAKE2B ad810d69ef1c9ed9aa377bcd986716a47c53f1a573b059c558aa0ec4dcfb884492037915864d604032ddbec1367d6f488b2a3bab8c3baec75423359fe39d8c40 SHA512 f14d3cb8c696ac1a77afc8f2905038697dd2a9b8a3e96646f5e687fce7856c0d5f397717b257d85ed5fca6cea2ac5e33a52a31256b8f2791ce36af765b4df6d3
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild
new file mode 100644
index 000000000000..3b8009a01722
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.17.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kwallet)
+ dev-libs/libgcrypt:0=
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}