summaryrefslogtreecommitdiff
path: root/kde-plasma/kwin/files
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwin/files')
-rw-r--r--kde-plasma/kwin/files/kwin-6.3.2.1-another-crashfix.patch34
-rw-r--r--kde-plasma/kwin/files/kwin-6.3.2.1-crashfix.patch46
-rw-r--r--kde-plasma/kwin/files/kwin-6.3.3-remove-pragma.patch29
-rw-r--r--kde-plasma/kwin/files/kwin-6.3.3-version.patch24
4 files changed, 53 insertions, 80 deletions
diff --git a/kde-plasma/kwin/files/kwin-6.3.2.1-another-crashfix.patch b/kde-plasma/kwin/files/kwin-6.3.2.1-another-crashfix.patch
deleted file mode 100644
index 7a0330c4deed..000000000000
--- a/kde-plasma/kwin/files/kwin-6.3.2.1-another-crashfix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://bugs.kde.org/show_bug.cgi?id=501181
-
-(This is a minimal backport of https://invent.kde.org/plasma/kwin/-/commit/e652bdd3118fa55563caf0125deb0999f5ebd503,
-but given the next release is on Tuesday, let's just go with the thing that
-is confirmed to work.)
-
-From d63e308604d6b45f5c572acd4f299e2c5cfbab44 Mon Sep 17 00:00:00 2001
-From: Mike Lothian <mike@fireburn.co.uk>
-Date: Fri, 7 Mar 2025 15:24:00 +0000
-Subject: [PATCH] Quick fix
-
----
- src/backends/drm/drm_gpu.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/backends/drm/drm_gpu.cpp b/src/backends/drm/drm_gpu.cpp
-index 4599b3d..a47f5ce 100644
---- a/src/backends/drm/drm_gpu.cpp
-+++ b/src/backends/drm/drm_gpu.cpp
-@@ -443,6 +443,10 @@ DrmPipeline::Error DrmGpu::testPendingConfiguration()
-
- DrmPipeline::Error DrmGpu::testPipelines()
- {
-+ if (m_pipelines.isEmpty()) {
-+ // nothing to do
-+ return DrmPipeline::Error::None;
-+ }
- QList<DrmPipeline *> inactivePipelines;
- std::copy_if(m_pipelines.constBegin(), m_pipelines.constEnd(), std::back_inserter(inactivePipelines), [](const auto pipeline) {
- return pipeline->enabled() && !pipeline->active();
---
-2.48.1
-
-
diff --git a/kde-plasma/kwin/files/kwin-6.3.2.1-crashfix.patch b/kde-plasma/kwin/files/kwin-6.3.2.1-crashfix.patch
deleted file mode 100644
index ef481cc513f3..000000000000
--- a/kde-plasma/kwin/files/kwin-6.3.2.1-crashfix.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-commit b97892417ec1649c780e85e403842a77a6ab87b6
-Author: Xaver Hugl <xaver.hugl@gmail.com>
-Date: Wed Feb 26 12:58:09 2025 +0100
-
- backends/drm: fix testing for more connectors than CRTCs
-
- The connectors may not actually be enabled, so the checks could sometimes result in
- wrongly returning Error::NotEnoughCrtcs.
-
- BUG: 500819
- CCBUG: 500797
-
- (cherry picked from commit aa11d89a90bc4eb77bfe191a2cadede4d957d2a9)
-
-diff --git a/src/backends/drm/drm_gpu.cpp b/src/backends/drm/drm_gpu.cpp
-index 9291b5296d..4599b3dc46 100644
---- a/src/backends/drm/drm_gpu.cpp
-+++ b/src/backends/drm/drm_gpu.cpp
-@@ -345,15 +345,7 @@ void DrmGpu::removeOutputs()
-
- DrmPipeline::Error DrmGpu::checkCrtcAssignment(QList<DrmConnector *> connectors, const QList<DrmCrtc *> &crtcs)
- {
-- if (connectors.isEmpty() || crtcs.isEmpty()) {
-- if (m_pipelines.isEmpty()) {
-- // nothing to do
-- return DrmPipeline::Error::None;
-- }
-- if (!connectors.empty()) {
-- // we have no crtcs left to drive the remaining connectors
-- return DrmPipeline::Error::InvalidArguments;
-- }
-+ if (connectors.isEmpty()) {
- return testPipelines();
- }
- auto connector = connectors.takeFirst();
-@@ -363,6 +355,10 @@ DrmPipeline::Error DrmGpu::checkCrtcAssignment(QList<DrmConnector *> connectors,
- pipeline->setCrtc(nullptr);
- return checkCrtcAssignment(connectors, crtcs);
- }
-+ if (crtcs.isEmpty()) {
-+ // we have no crtc left to drive this connector
-+ return DrmPipeline::Error::InvalidArguments;
-+ }
- DrmCrtc *currentCrtc = nullptr;
- if (m_atomicModeSetting) {
- // try the crtc that this connector is already connected to first
diff --git a/kde-plasma/kwin/files/kwin-6.3.3-remove-pragma.patch b/kde-plasma/kwin/files/kwin-6.3.3-remove-pragma.patch
new file mode 100644
index 000000000000..556a41681423
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-6.3.3-remove-pragma.patch
@@ -0,0 +1,29 @@
+From a3249e495907f0090119fc92e5d33530e0c4c285 Mon Sep 17 00:00:00 2001
+From: Ismael Asensio <isma.af@gmail.com>
+Date: Tue, 11 Mar 2025 20:48:15 +0100
+Subject: [PATCH] kcms/rules: Remove pragma on OptionsComboBox
+
+It is suggested by qmlls, but this seems to cause graphical artifacts
+on some systems, rendering the comboboxes unusable
+
+BUG: 501357
+---
+ src/kcms/rules/ui/OptionsComboBox.qml | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/kcms/rules/ui/OptionsComboBox.qml b/src/kcms/rules/ui/OptionsComboBox.qml
+index 5a5d02eee9..d8a2eb8bf0 100644
+--- a/src/kcms/rules/ui/OptionsComboBox.qml
++++ b/src/kcms/rules/ui/OptionsComboBox.qml
+@@ -11,8 +11,6 @@ import QtQuick.Controls as QQC2
+ import org.kde.kirigami 2.10 as Kirigami
+ import org.kde.kcms.kwinrules
+
+-pragma ComponentBehavior: Bound
+-
+
+ QQC2.ComboBox {
+ id: optionsCombo
+--
+GitLab
+
diff --git a/kde-plasma/kwin/files/kwin-6.3.3-version.patch b/kde-plasma/kwin/files/kwin-6.3.3-version.patch
new file mode 100644
index 000000000000..cfb544b4d7fc
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-6.3.3-version.patch
@@ -0,0 +1,24 @@
+From 0005710eccdf702915ec776830c79102a6b66f1b Mon Sep 17 00:00:00 2001
+From: Jonathan Riddell <jr@jriddell.org>
+Date: Tue, 25 Feb 2025 16:45:29 +0000
+Subject: [PATCH] update version for new release
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6ab65f06bf8..61932a493c1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ cmake_minimum_required(VERSION 3.16)
+
+-set(PROJECT_VERSION "6.3.2") # Handled by release scripts
++set(PROJECT_VERSION "6.3.3") # Handled by release scripts
+ project(KWin VERSION ${PROJECT_VERSION})
+
+ set(CMAKE_C_STANDARD 99)
+--
+GitLab
+