summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-meta
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-meta')
-rw-r--r--kde-plasma/plasma-meta/Manifest1
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-6.1.5.ebuild146
2 files changed, 147 insertions, 0 deletions
diff --git a/kde-plasma/plasma-meta/Manifest b/kde-plasma/plasma-meta/Manifest
index e9a5e551ef56..5cd658227efe 100644
--- a/kde-plasma/plasma-meta/Manifest
+++ b/kde-plasma/plasma-meta/Manifest
@@ -1,3 +1,4 @@
EBUILD plasma-meta-5.27.11-r2.ebuild 4216 BLAKE2B 52a4b3e6b4f18d3881f29883ef9510e7ee9f8b5be5645f2fd4285e08b8af3d7371f5b5d29f0a6897c32a1b8f86f123750bab380de6e7e0c7776cb05d84f0f8ec SHA512 456e5d864a99dc50b642f8965529c6ed465f670cf01a2d1be2297bbea5098a802dd96c75b29ab0786591806a98c885b34ff6e516d750705483b97d5a846993d3
EBUILD plasma-meta-6.1.4-r1.ebuild 5365 BLAKE2B e8d4af46ba048760667ef1423ac4914c3dcf1ab9c206620c3b7d110fffdb7b8d03c6fabfe86f2f2efb9c26338a6b59fdccd7335bdce1393809d8f69c375143a0 SHA512 b76deb1a50ba8aa95a2464d3c967fe9328ef8766d38449fc0f456beb32f5e5a20d0caf7d64977dc21429868a924416963e2892b94c50ec26c10aa640411a215d
+EBUILD plasma-meta-6.1.5.ebuild 5434 BLAKE2B 77906e6279e74673ad6ac4c6cc3ba2295f8eab64cb594003d42c9a68a6247408c2175d6b58085859cd07cace6cb41af24cbc0bfca6963629c375078b40e843a1 SHA512 03eef8355207e9067ab4c2a1be3880ba4148e05ffe9192a5fd75bdbf0a13bea32a381eafc0b96aa8bb211c46f7727d67eee1969e7769f53bea0bb0478595fcf0
MISC metadata.xml 3059 BLAKE2B d3e3485ebb608a603d13f0263533dd97d04ed0f9e9610ee429808f521770a92e59f9fea4992c8d280139cfbe5468029af073813d8195745c7182ae56a95e5d2a SHA512 0576008409be1377c1ac443aad3d039a525e62aba4b7fc93230869a0054640abea0ba40ea69aa3013a8ec7ad48e0c35ba312468626fee5662b41ccaaf86ceb63
diff --git a/kde-plasma/plasma-meta/plasma-meta-6.1.5.ebuild b/kde-plasma/plasma-meta/plasma-meta-6.1.5.ebuild
new file mode 100644
index 000000000000..081ef93f62bf
--- /dev/null
+++ b/kde-plasma/plasma-meta/plasma-meta-6.1.5.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Merge this to pull in all Plasma 6 packages"
+HOMEPAGE="https://kde.org/plasma-desktop/"
+
+LICENSE="metapackage"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="accessibility bluetooth +browser-integration colord +crash-handler crypt
+cups discover +display-manager +elogind +firewall flatpak grub gtk +kwallet
++networkmanager oxygen-theme plymouth pulseaudio qt5 rdp +sddm sdk +smart systemd
+thunderbolt unsupported wacom +wallpapers webengine +xwayland"
+
+REQUIRED_USE="^^ ( elogind systemd )"
+
+RDEPEND="
+ !${CATEGORY}/${PN}:5
+ !kde-plasma/khotkeys:5
+ >=kde-plasma/breeze-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/kactivitymanagerd-${PV}:${SLOT}
+ >=kde-plasma/kde-cli-tools-${PV}:${SLOT}
+ >=kde-plasma/kde-cli-tools-common-${PV}
+ >=kde-plasma/kdecoration-${PV}:${SLOT}
+ >=kde-plasma/kdeplasma-addons-${PV}:${SLOT}
+ >=kde-plasma/kdesu-gui-${PV}
+ >=kde-plasma/kgamma-${PV}:${SLOT}
+ >=kde-plasma/kglobalacceld-${PV}:${SLOT}
+ >=kde-plasma/kinfocenter-${PV}:${SLOT}
+ >=kde-plasma/kmenuedit-${PV}:${SLOT}
+ >=kde-plasma/kpipewire-${PV}:${SLOT}
+ >=kde-plasma/kscreen-${PV}:${SLOT}
+ >=kde-plasma/kscreenlocker-${PV}:${SLOT}
+ >=kde-plasma/ksshaskpass-${PV}:${SLOT}
+ >=kde-plasma/ksystemstats-${PV}:${SLOT}
+ >=kde-plasma/kwayland-${PV}:${SLOT}
+ >=kde-plasma/kwin-${PV}:${SLOT}[lock]
+ >=kde-plasma/kwrited-${PV}:${SLOT}
+ >=kde-plasma/layer-shell-qt-${PV}:${SLOT}
+ >=kde-plasma/libkscreen-${PV}:${SLOT}
+ >=kde-plasma/libksysguard-${PV}:${SLOT}
+ >=kde-plasma/libplasma-${PV}:${SLOT}
+ >=kde-plasma/milou-${PV}:${SLOT}
+ >=kde-plasma/ocean-sound-theme-${PV}:${SLOT}
+ >=kde-plasma/plasma-activities-${PV}:${SLOT}
+ >=kde-plasma/plasma-activities-stats-${PV}:${SLOT}
+ >=kde-plasma/plasma-desktop-${PV}:${SLOT}
+ >=kde-plasma/plasma-integration-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/plasma-systemmonitor-${PV}:${SLOT}
+ >=kde-plasma/plasma-welcome-${PV}:${SLOT}
+ >=kde-plasma/plasma-workspace-${PV}:${SLOT}
+ >=kde-plasma/plasma5support-${PV}:${SLOT}
+ >=kde-plasma/polkit-kde-agent-${PV}:*
+ >=kde-plasma/powerdevil-${PV}:${SLOT}
+ >=kde-plasma/qqc2-breeze-style-${PV}:${SLOT}
+ >=kde-plasma/systemsettings-${PV}:${SLOT}
+ >=kde-plasma/xdg-desktop-portal-kde-${PV}:${SLOT}
+ sys-apps/dbus[elogind?,systemd?]
+ sys-auth/polkit[systemd?]
+ sys-fs/udisks:2[elogind?,systemd?]
+ bluetooth? ( >=kde-plasma/bluedevil-${PV}:${SLOT} )
+ browser-integration? ( >=kde-plasma/plasma-browser-integration-${PV}:${SLOT} )
+ colord? ( x11-misc/colord )
+ crash-handler? ( >=kde-plasma/drkonqi-${PV}:${SLOT} )
+ crypt? ( >=kde-plasma/plasma-vault-${PV}:${SLOT} )
+ cups? ( >=kde-plasma/print-manager-${PV}:${SLOT} )
+ discover? ( >=kde-plasma/discover-${PV}:${SLOT} )
+ display-manager? (
+ sddm? (
+ >=kde-plasma/sddm-kcm-${PV}:${SLOT}
+ >=x11-misc/sddm-0.21.0_p20240302[elogind?,systemd?]
+ )
+ !sddm? ( x11-misc/lightdm )
+ )
+ elogind? ( sys-auth/elogind[pam] )
+ flatpak? ( >=kde-plasma/flatpak-kcm-${PV}:${SLOT} )
+ grub? ( >=kde-plasma/breeze-grub-${PV}:${SLOT} )
+ gtk? (
+ >=kde-plasma/breeze-gtk-${PV}:${SLOT}
+ >=kde-plasma/kde-gtk-config-${PV}:${SLOT}
+ sys-apps/xdg-desktop-portal-gtk
+ x11-misc/appmenu-gtk-module
+ )
+ kwallet? ( >=kde-plasma/kwallet-pam-${PV}:${SLOT} )
+ networkmanager? (
+ >=kde-plasma/plasma-nm-${PV}:${SLOT}
+ net-misc/networkmanager[elogind?,systemd?]
+ )
+ oxygen-theme? (
+ >=kde-frameworks/oxygen-icons-6.0.0:*
+ >=kde-plasma/oxygen-${PV}:${SLOT}[qt5?]
+ >=kde-plasma/oxygen-sounds-${PV}:${SLOT}
+ )
+ plymouth? (
+ >=kde-plasma/breeze-plymouth-${PV}:${SLOT}
+ >=kde-plasma/plymouth-kcm-${PV}:${SLOT}
+ )
+ pulseaudio? ( >=kde-plasma/plasma-pa-${PV}:${SLOT} )
+ qt5? ( >=kde-plasma/kwayland-integration-${PV}:5 )
+ rdp? ( >=kde-plasma/krdp-${PV}:${SLOT} )
+ sdk? ( >=kde-plasma/plasma-sdk-${PV}:${SLOT} )
+ smart? ( >=kde-plasma/plasma-disks-${PV}:${SLOT} )
+ systemd? (
+ sys-apps/systemd[pam]
+ firewall? ( >=kde-plasma/plasma-firewall-${PV}:${SLOT} )
+ )
+ thunderbolt? ( >=kde-plasma/plasma-thunderbolt-${PV}:${SLOT} )
+ !unsupported? (
+ !gui-apps/qt6ct
+ )
+ wacom? ( >=kde-plasma/wacomtablet-${PV}:${SLOT} )
+ wallpapers? ( >=kde-plasma/plasma-workspace-wallpapers-${PV}:${SLOT} )
+ webengine? ( kde-apps/khelpcenter:6 )
+ xwayland? ( >=gui-apps/xwaylandvideobridge-0.4.0 )
+"
+# Optional runtime deps: kde-plasma/plasma-desktop
+RDEPEND="${RDEPEND}
+ accessibility? ( app-accessibility/orca )
+"
+
+pkg_postinst() {
+ if [[ $(tc-get-cxx-stdlib) == "libc++" ]] ; then
+ # Workaround for bug #923292 (KDE-bug 479679)
+ ewarn "plasmashell and other KDE Plasma components are known to misbehave"
+ ewarn "when built with sys-libs/libcxx, e.g. crashing when right-clicking"
+ ewarn "on a panel. See bug #923292."
+ ewarn ""
+ ewarn "A possible (no warranty!) workaround is building sys-libs/libcxx and"
+ ewarn "sys-libs/libcxxabi with the following in package.env:"
+ ewarn " MYCMAKEARGS=\"-DLIBCXX_TYPEINFO_COMPARISON_IMPLEMENTATION=2\""
+ ewarn "You may then need to rebuild dev-qt/* and kde-*/*."
+ fi
+
+ if ! use qt5 && has_version dev-qt/qtgui; then
+ ewarn "KF5- and Qt5-based applications will exhibit various integration bugs"
+ ewarn "and generally look out of place in Plasma 6 without the dependencies"
+ ewarn "enforced by kde-plasma/plasma-meta[qt5]."
+ ewarn
+ ewarn "This warning message is being displayed because dev-qt/qtgui:5 is"
+ ewarn "currently installed which indicates the use of such applications."
+ fi
+}