summaryrefslogtreecommitdiff
path: root/llvm-runtimes/flang-rt
diff options
context:
space:
mode:
Diffstat (limited to 'llvm-runtimes/flang-rt')
-rw-r--r--llvm-runtimes/flang-rt/Manifest2
-rw-r--r--llvm-runtimes/flang-rt/flang-rt-21.0.0_pre20250311.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/llvm-runtimes/flang-rt/Manifest b/llvm-runtimes/flang-rt/Manifest
index a3e3e67cd396..cfe65934483f 100644
--- a/llvm-runtimes/flang-rt/Manifest
+++ b/llvm-runtimes/flang-rt/Manifest
@@ -1,4 +1,6 @@
DIST llvm-project-7e8a06cfa4a2951b8ee77e19e34926e6e535b4d1.tar.gz 228792296 BLAKE2B cd9357bdca9342770820f9fadfbd0b129a83324847f18e2ebac1fed8df4afb101aba2dc19d90264ae1e2d5692e34149ca24ef82a4973e7aeddb157268bb411b6 SHA512 9821a34a559e1db596940d76ce9388360baea43c1a9de814f567bfcf1428a0c6e3ced61b1e07537058454785d9c3aa3f443cbcf742a01fb40dd20b476a906442
+DIST llvm-project-cb7298f66d62a3548fcf3bd230304067ecf30d17.tar.gz 229200711 BLAKE2B 1910569812e7423cf566b0dec67269404ba8db8232ab293bc603a88914f2b756e3088bf2133c0fca612cc58d39691c7b813b3c5839a7ac9a3d177fe6bde766c6 SHA512 07c3f6ce34e7d32c5ebce1d2efb77e6a1dde49f9eedf7191733a20bdcb6ffd0c03f8fc8de85fd00bd9465b209f140639a68a367d2218c028bfa6e06067cc3e14
EBUILD flang-rt-21.0.0.9999.ebuild 1687 BLAKE2B 089e6eaa9be55f3f6646fa548c5ce5ebe43c5fe83207d251d66233eb7859b76c95574c069283a8bd8d0a1d09eeaab876c14f155fe0dbb1262c9e986836e2dd66 SHA512 704b60904682b6b99f9b3c8d5ffadbe4901099a8691291fd82982408c83e0f1aee11e39465b5f9f068bfa534ae2003ec9117ab2a9b12691f7e5c3c689e3059fe
EBUILD flang-rt-21.0.0_pre20250301.ebuild 1687 BLAKE2B 089e6eaa9be55f3f6646fa548c5ce5ebe43c5fe83207d251d66233eb7859b76c95574c069283a8bd8d0a1d09eeaab876c14f155fe0dbb1262c9e986836e2dd66 SHA512 704b60904682b6b99f9b3c8d5ffadbe4901099a8691291fd82982408c83e0f1aee11e39465b5f9f068bfa534ae2003ec9117ab2a9b12691f7e5c3c689e3059fe
+EBUILD flang-rt-21.0.0_pre20250311.ebuild 1687 BLAKE2B 089e6eaa9be55f3f6646fa548c5ce5ebe43c5fe83207d251d66233eb7859b76c95574c069283a8bd8d0a1d09eeaab876c14f155fe0dbb1262c9e986836e2dd66 SHA512 704b60904682b6b99f9b3c8d5ffadbe4901099a8691291fd82982408c83e0f1aee11e39465b5f9f068bfa534ae2003ec9117ab2a9b12691f7e5c3c689e3059fe
MISC metadata.xml 299 BLAKE2B 2feead2cd1b35b3a43335ddd7711f8181b52bc63ee7166608914260c67528add5251349063afbef4f8cf0ec09b2cd4c3ffdd90f2c14ed60bb69ebc03888f6333 SHA512 cd745c54ab18d25bdaff18582105072574103a36cfe7c175ef740f266d00e9fc6f44c332904d23b911c939cf5bdf52973b388923099d8dd5dfef3c283b5cb685
diff --git a/llvm-runtimes/flang-rt/flang-rt-21.0.0_pre20250311.ebuild b/llvm-runtimes/flang-rt/flang-rt-21.0.0_pre20250311.ebuild
new file mode 100644
index 000000000000..30245857a84e
--- /dev/null
+++ b/llvm-runtimes/flang-rt/flang-rt-21.0.0_pre20250311.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic llvm.org
+
+DESCRIPTION="LLVM's Fortran runtime"
+HOMEPAGE="https://flang.llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions"
+SLOT="${LLVM_MAJOR}"
+IUSE="+debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<llvm-core/flang-21.0.0_pre20250221-r1
+"
+BDEPEND="
+ llvm-core/llvm:${LLVM_MAJOR}
+ llvm-core/flang
+ test? (
+ dev-python/lit
+ )
+"
+
+LLVM_COMPONENTS=(
+ runtimes flang-rt cmake flang llvm/{cmake,utils/llvm-lit}
+)
+llvm.org_set_globals
+
+src_configure() {
+ # the code is not portable
+ local -x FC=flang F77=flang
+ strip-unsupported-flags
+
+ local mycmakeargs=(
+ # we may not have a runtime yet
+ -DCMAKE_Fortran_COMPILER_WORKS=TRUE
+
+ -DLLVM_ENABLE_RUNTIMES="flang-rt"
+ # this package forces NO_DEFAULT_PATHS
+ -DLLVM_BINARY_DIR="${ESYSROOT}/usr/lib/llvm/${LLVM_MAJOR}"
+
+ -DFLANG_RT_INCLUDE_TESTS=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
+ )
+
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+ cmake_src_configure
+}
+
+src_test() {
+ # respect TMPDIR!
+ local -x LIT_PRESERVES_TMP=1
+ cmake_build check-flang-rt
+}
+
+src_install() {
+ cmake_src_install
+
+ # in standalone build, the library is installed to (incorrect) resource dir
+ # but the driver only looks for it in lib (sigh)
+ # https://github.com/llvm/llvm-project/issues/127538
+ mkdir -p "${ED}/usr/lib/llvm/${LLVM_MAJOR}" || die
+ mv "${ED}/usr/$(get_libdir)/clang/${LLVM_MAJOR}/lib"/* \
+ "${ED}/usr/lib/llvm/${LLVM_MAJOR}/lib" || die
+}