summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-config/lxqt-config-0.14.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-config/lxqt-config-0.14.1-r1.ebuild')
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.14.1-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.14.1-r1.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.14.1-r1.ebuild
index 263309fa6e7b..33b97791a6a3 100644
--- a/lxqt-base/lxqt-config/lxqt-config-0.14.1-r1.ebuild
+++ b/lxqt-base/lxqt-config/lxqt-config-0.14.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="LXQt system configuration control center"
HOMEPAGE="https://lxqt.org/"
@@ -20,6 +20,8 @@ LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
SLOT="0"
IUSE="+monitor +touchpad"
+PATCHES=( "${FILESDIR}/${P}-qt-5.14-build.patch" )
+
BDEPEND="
dev-qt/linguist-tools:5
>=dev-util/lxqt-build-tools-0.6.0
@@ -57,11 +59,11 @@ src_configure() {
-DWITH_MONITOR="$(usex monitor)"
-DWITH_TOUCHPAD="$(usex touchpad)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
}