summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild')
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild
new file mode 100644
index 000000000000..9cbfbe3ee0d5
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.10.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"