summaryrefslogtreecommitdiff
path: root/mail-client/alot/alot-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/alot/alot-0.8.1.ebuild')
-rw-r--r--mail-client/alot/alot-0.8.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/mail-client/alot/alot-0.8.1.ebuild b/mail-client/alot/alot-0.8.1.ebuild
index 809ff797b5ab..7594d4ca93e0 100644
--- a/mail-client/alot/alot-0.8.1.ebuild
+++ b/mail-client/alot/alot-0.8.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -23,7 +23,7 @@ RDEPEND="
dev-python/python-magic[${PYTHON_USEDEP}]
>=dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
>=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.4[${PYTHON_USEDEP}]
net-mail/mailbase
>=net-mail/notmuch-0.27[crypt,python]
"
@@ -38,6 +38,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}/${PV}-0001-remove-non-working-test.patch"
+ "${FILESDIR}/${PV}-0002-changed-expired-test-keys.patch"
)
python_compile_all() {