summaryrefslogtreecommitdiff
path: root/mail-client/claws-mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/claws-mail')
-rw-r--r--mail-client/claws-mail/Manifest1
-rw-r--r--mail-client/claws-mail/claws-mail-9999.ebuild210
2 files changed, 211 insertions, 0 deletions
diff --git a/mail-client/claws-mail/Manifest b/mail-client/claws-mail/Manifest
index a45446f0afaa..af3add452723 100644
--- a/mail-client/claws-mail/Manifest
+++ b/mail-client/claws-mail/Manifest
@@ -5,4 +5,5 @@ DIST claws-mail-3.16.0.tar.xz 5913948 BLAKE2B 6744045de6bc3945221569a9ae1cdcd849
EBUILD claws-mail-3.15.0-r2.ebuild 5779 BLAKE2B a12a18396d038ea3b8f70d67c756c2999deaabf3a91ac56bf786672cf305f4f725ce7d67303ceea5bd05d9b8f4dca5ce30a9274a26f40bb16be53a81f6ae8054 SHA512 da59097b2d7f9dea4a362297979c7a684f49baf056b7f58ec09a4c0d2b0cc895f298539c571b80ac7a6fddb8c27672889ccfd7673d33e3de826ee1c9eae69d12
EBUILD claws-mail-3.15.1.ebuild 5722 BLAKE2B 83c5b02d2b93d40951a64cb01518baf568cbc9fdab952e6987474d72af1177de615e85dd352c949453a39f49aacd5564419614155a5eea0a08edbd54e3167868 SHA512 71c46238ddecf2a9470f00cda4fe37514e77bb951dc7ef12e9cecc61a929be977dded55b587e6401703ec27c5e822b259b2af13b5716f1fa75ec7d61ecc5c3e8
EBUILD claws-mail-3.16.0.ebuild 5727 BLAKE2B 9d09a2252f3c37951771ae7c3bb7700368f7298bd1218467086011d5ed50f11f2049ab2e389b3a1fcd0d31769639a83359e0868618baf8350df769456bf8ddf5 SHA512 90dbd1adb59d2886eaa6ed700fbf83648bd0550e131febf884fdde4ec7146234dce8fa1ceec0c9a1e111a109ea761d547d9f7581c26ba1ccceab1ba9f4eb298a
+EBUILD claws-mail-9999.ebuild 5844 BLAKE2B 9217492f267b0c30a1cd2b3a6ad53d311f1fc6687279bc2043c387592be4a7eac365b2b9f6d1f41664fefdb4cccd3c95a4a9ed2e215694862707817d1c544b33 SHA512 a47a11ffede58f70141a99b437beebf81d5010ff8ee9573ab299f1f4a95b6eeb5b3fbbbcde02382b8e27240a618e2d6074eff782a24cd06626eadd3837295d33
MISC metadata.xml 1601 BLAKE2B 7827fe2821ee1e9a6ddc747f269de28106a0ad9855fce1a298a0bef5a00de1383d0798bd3239e888dd0f88b477112ec14d4dcb9488c1709d6064b9fe9a2bad13 SHA512 824a2702d57d86e0ebfd451e12f374010559956e5770c65028c819b799de4e72a156c80587278fff7d246a5f402aeee8a30fae53a4c84a8922cd050a7c1c9340
diff --git a/mail-client/claws-mail/claws-mail-9999.ebuild b/mail-client/claws-mail/claws-mail-9999.ebuild
new file mode 100644
index 000000000000..065ab0571e88
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-9999.ebuild
@@ -0,0 +1,210 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org/"
+
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.claws-mail.org/claws.git"
+else
+ SRC_URI="http://www.claws-mail.org/download.php?file=releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="archive bogofilter calendar clamav dbus debug doc gdata +gnutls gtk3 +imap ipv6 ldap +libcanberra +libindicate +libnotify networkmanager nls nntp +notification pda pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
+REQUIRED_USE="libcanberra? ( notification )
+ libindicate? ( notification )
+ libnotify? ( notification )
+ networkmanager? ( dbus )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ smime? ( pgp )"
+
+COMMONDEPEND="
+ net-mail/ytnef
+ archive? (
+ app-arch/libarchive
+ >=net-misc/curl-7.9.7
+ )
+ bogofilter? ( mail-filter/bogofilter )
+ calendar? (
+ >=dev-libs/libical-2.0.0
+ >=net-misc/curl-7.9.7
+ )
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ gdata? ( >=dev-libs/libgdata-0.17.2 )
+ gnutls? ( >=net-libs/gnutls-3.0 )
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( >=x11-libs/gtk+-2.24:2 )
+ imap? ( >=net-libs/libetpan-0.57 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ nls? ( >=sys-devel/gettext-0.18 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ notification? (
+ dev-libs/glib:2
+ libcanberra? ( media-libs/libcanberra[gtk] )
+ libindicate? ( dev-libs/libindicate:3[gtk] )
+ libnotify? ( x11-libs/libnotify )
+ )
+ pda? ( >=app-pda/jpilot-0.99 )
+ pdf? ( app-text/poppler[cairo] )
+ pgp? ( >=app-crypt/gpgme-1.0.0 )
+ session? (
+ x11-libs/libICE
+ x11-libs/libSM
+ )
+ smime? ( >=app-crypt/gpgme-1.0.0 )
+ spam-report? ( >=net-misc/curl-7.9.7 )
+ spell? ( >=app-text/enchant-1.0.0 )
+ startup-notification? ( x11-libs/startup-notification )
+ svg? ( >=gnome-base/librsvg-2.40.5 )
+ valgrind? ( dev-util/valgrind )
+"
+
+DEPEND="${COMMONDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ xface? ( >=media-libs/compface-1.4 )"
+
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info
+ clamav? ( app-antivirus/clamav )
+ networkmanager? ( net-misc/networkmanager )
+ pdf? ( app-text/ghostscript-gpl )
+ perl? ( dev-lang/perl:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.10.3
+ )
+ rss? (
+ dev-libs/libxml2
+ net-misc/curl
+ )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Don't use libsoup-gnome (bug #565924)
+ export HAVE_LIBSOUP_GNOME=no
+
+ local myeconfargs=(
+ --disable-bsfilter-plugin
+ --disable-fancy-plugin
+ --disable-generic-umpc
+ --enable-acpi_notifier-plugin
+ --enable-address_keeper-plugin
+ --enable-alternate-addressbook
+ --enable-att_remover-plugin
+ --enable-attachwarner-plugin
+ --enable-fetchinfo-plugin
+ --enable-mailmbox-plugin
+ --enable-newmail-plugin
+ --enable-tnef_parse-plugin
+ --with-password-encryption=$(usex gnutls gnutls old)
+ $(use_enable archive archive-plugin)
+ $(use_enable bogofilter bogofilter-plugin)
+ $(use_enable calendar vcalendar-plugin)
+ $(use_enable clamav clamd-plugin)
+ $(use_enable dbus)
+ $(use_enable debug crash-dialog)
+ $(use_enable doc manual)
+ $(use_enable gdata gdata-plugin)
+ $(use_enable gnutls)
+ $(use_enable gtk3)
+ $(use_enable ipv6)
+ $(use_enable ldap)
+ $(use_enable networkmanager)
+ $(use_enable nls)
+ $(use_enable notification notification-plugin)
+ $(use_enable pda jpilot)
+ $(use_enable pdf pdf_viewer-plugin)
+ $(use_enable perl perl-plugin)
+ $(use_enable pgp pgpcore-plugin)
+ $(use_enable pgp pgpinline-plugin)
+ $(use_enable pgp pgpmime-plugin)
+ $(use_enable python python-plugin)
+ $(use_enable rss rssyl-plugin)
+ $(use_enable session libsm)
+ $(use_enable sieve managesieve-plugin)
+ $(use_enable smime smime-plugin)
+ $(use_enable spam-report spam_report-plugin)
+ $(use_enable spamassassin spamassassin-plugin)
+ $(use_enable spell enchant)
+ $(use_enable startup-notification)
+ $(use_enable svg)
+ $(use_enable valgrind valgrind)
+ $(use_enable xface compface)
+ )
+
+ # libetpan is needed if user wants nntp or imap functionality
+ if use imap || use nntp ; then
+ myeconfargs+=( --enable-libetpan )
+ else
+ myeconfargs+=( --disable-libetpan )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+ default
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png
+ local size
+ for size in 64 128 ; do
+ newicon -s ${size} ${PN}-${size}x${size}.png ${PN}.png
+ done
+
+ docinto tools
+ dodoc tools/README*
+
+ domenu ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools || die
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh
+ doexe tb2claws-mail update-po uudec uuooffice
+
+ # kill useless files
+ rm -f "${ED%/}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ ewarn "When upgrading from version 3.9.0 or below some changes have happened:"
+ ewarn "- There are no individual plugins in mail-client/claws-mail-* anymore, but they are integrated mostly controlled through USE flags"
+ ewarn "- Plugins with no special dependencies are just built and can be loaded through the interface"
+ ewarn "- The gtkhtml2, dillo and trayicon plugins have been dropped entirely"
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}