summaryrefslogtreecommitdiff
path: root/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild')
-rw-r--r--mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild
deleted file mode 100644
index f05292d8f63e..000000000000
--- a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module systemd xdg-utils
-
-MY_PN="${PN/-mail/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Serves ProtonMail to IMAP/SMTP clients"
-HOMEPAGE="https://proton.me/mail/bridge https://github.com/ProtonMail/proton-bridge/"
-SRC_URI="https://github.com/ProtonMail/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 GPL-3+ ISC LGPL-3+ MIT MPL-2.0 Unlicense"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="gui"
-
-# Quite a few tests require Internet access
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND="app-crypt/libsecret"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-src_prepare() {
- xdg_environment_reset
- default
-}
-
-src_compile() {
- if use gui; then
- eerror "Since version 3.0.0, GUI support in ${PN} requires Qt6 and is therefore currently not available"
- die "USE=gui requires Qt6"
- else
- emake build-nogui
- fi
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- exeinto /usr/bin
- newexe bridge ${PN}
-
- systemd_newuserunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-
- einstalldocs
-}
-
-pkg_postinst() {
- use gui && xdg_icon_cache_update
-}
-
-pkg_postrm() {
- use gui && xdg_icon_cache_update
-}