summaryrefslogtreecommitdiff
path: root/mail-mta/sendmail
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/sendmail')
-rw-r--r--mail-mta/sendmail/Manifest2
-rw-r--r--mail-mta/sendmail/sendmail-8.16.1.ebuild29
2 files changed, 17 insertions, 14 deletions
diff --git a/mail-mta/sendmail/Manifest b/mail-mta/sendmail/Manifest
index 47ad7b3ffe5d..707f1ddb711a 100644
--- a/mail-mta/sendmail/Manifest
+++ b/mail-mta/sendmail/Manifest
@@ -14,5 +14,5 @@ AUX sm-client.service 418 BLAKE2B a9057cac008c11d3cfd5a4b662cf3fc71a33be79e8890a
DIST sendmail.8.15.2.tar.gz 2207417 BLAKE2B 3d9dfb5bc2b535e30ef2fc61333e12a9b1fc45a5d730d2bed1ef956adb574721833f87aeba0475705b76e0c7d6cf00f9a10025bffb0de6c6b4dae606eb2ec399 SHA512 04feb37316c13b66b1518596507a7da7c16cb0bf1abf10367f7fd888a428fadb093a9efa55342fa55b936c3f0cbdc63b9e2505cd99201a69a0c05b8ad65f49f9
DIST sendmail.8.16.1.tar.gz 2236402 BLAKE2B 80a9c2f1d04719099703e55f0a0c54fd638cf69b72839d358ae6863c95c9e0965d1b7fdd5b1807bec1ffdf87bca0c7c9ba91060962e6de5da5bf14422f6279ea SHA512 d7d4aac3c6d7505782abdb166204901b8b51cac000d610dfe40eda9eef7441a073af9e8e0b14c8719b07b445f55a1e2c28ac63d663d0daa7f1eafc5a101788b2
EBUILD sendmail-8.15.2-r2.ebuild 7259 BLAKE2B c30fe7036eb3e65dc6c83574984e5ca887c6f9ac6a5cf6eeba929b475cfc0514accf87b7a289f953260f52d30a881197cf9791713161b64daa73816041d8d0ee SHA512 5d0b2189cbbfd8765d71dcdec262841a5b32a38f7393406e92fe72acd4a28825988ece85e2e7dedd83442d00eab04d8518c82d3c7e5094a6c84a7120613368c5
-EBUILD sendmail-8.16.1.ebuild 6372 BLAKE2B eade89d5d472b53edf2732b7322f0a0d88c44d2b6288b9488bf2d52489ec0634ddb866cc5bc9fea3fbd7f3943f293a645acee95fb39e568e08cdf9662cf27a91 SHA512 4953d88700d707d2ef8fb5324211c5eee8de0487fa45a68ad12251bbb6bc86c1df49275cf68be3a7c12cfd5fd10dcb54bb55f5ca544617f50863a3860f957ad6
+EBUILD sendmail-8.16.1.ebuild 6541 BLAKE2B 38a17e69978704632c4e9aab0e59b2b4c92fb8420c2dfd077cd11df98141cff3001809ce8026f4c95193cfead069e09d86e257d9b20c60ee50f9c6cd303a6680 SHA512 1b87bd6e32985ff14c97b73ff819e771ad61ad0b0560b4ffa8faac30db3a4115421cba0fbe8cda1818d136fdae4e1401bb6c3ce1d30b4416a2e261b862fecb86
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/mail-mta/sendmail/sendmail-8.16.1.ebuild b/mail-mta/sendmail/sendmail-8.16.1.ebuild
index bd72f71759ce..edb48e9e4712 100644
--- a/mail-mta/sendmail/sendmail-8.16.1.ebuild
+++ b/mail-mta/sendmail/sendmail-8.16.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -55,6 +55,8 @@ src_prepare() {
local confENVDEF="-DMAXDAEMONS=64"
local conf_sendmail_LIBS=""
+ confENVDEF="${confLIBS} -DHAS_GETHOSTBYNAME2=1"
+
use sasl && confLIBS="${confLIBS} -lsasl2" \
&& confENVDEF="${confENVDEF} -DSASL=2" \
&& confCCOPTS="${confCCOPTS} -I/usr/include/sasl" \
@@ -87,7 +89,7 @@ src_prepare() {
-e "s/@@conf_sendmail_LIBS@@/${conf_sendmail_LIBS}/" \
"${FILESDIR}"/site.config.m4 > devtools/Site/site.config.m4 || die "sed failed"
- echo "APPENDDEF(\`confLIBDIRS', \`-L${EROOT}/usr/$(get_libdir)')" >> devtools/Site/site.config.m4 || die "echo failed"
+ echo "APPENDDEF(\`confLIBDIRS', \`-L${EPREFIX}/usr/$(get_libdir)')" >> devtools/Site/site.config.m4 || die "echo failed"
eapply_user
}
@@ -144,37 +146,38 @@ src_install() {
newdoc cf/README README.cf
newdoc cf/cf/README README.install-cf
- cp -pPR cf/* "${D}"/usr/share/sendmail-cf || die "copy failed"
+ cp -pPR cf/* "${ED}"/usr/share/sendmail-cf || die "copy failed"
docinto contrib
dodoc contrib/*
insinto /etc/mail
- if use mbox
- then
+ if use mbox; then
newins "${FILESDIR}"/sendmail.mc-r1 sendmail.mc
else
newins "${FILESDIR}"/sendmail-procmail.mc sendmail.mc
fi
- m4 "${D}"/usr/share/sendmail-cf/m4/cf.m4 "${D}"/etc/mail/sendmail.mc \
- > "${D}"/etc/mail/sendmail.cf || die "cf.m4 failed"
+ # See discussion on bug #730890
+ m4 "${ED}"/usr/share/sendmail-cf/m4/cf.m4 \
+ <(grep -v "${EPREFIX}"/usr/share/sendmail-cf/m4/cf.m4 "${ED}"/etc/mail/sendmail.mc) \
+ > "${ED}"/etc/mail/sendmail.cf || die "cf.m4 failed"
echo "include(\`/usr/share/sendmail-cf/m4/cf.m4')dnl" \
- > "${D}"/etc/mail/submit.mc || die "echo failed"
+ > "${ED}"/etc/mail/submit.mc || die "echo failed"
- cat "${D}"/usr/share/sendmail-cf/cf/submit.mc >> "${D}"/etc/mail/submit.mc || die "submit.mc cat failed"
+ cat "${ED}"/usr/share/sendmail-cf/cf/submit.mc >> "${ED}"/etc/mail/submit.mc || die "submit.mc cat failed"
echo "# local-host-names - include all aliases for your machine here" \
> "${D}"/etc/mail/local-host-names || die "local-host-names echo failed"
- cat <<- EOF > "${D}"/etc/mail/trusted-users
+ cat <<- EOF > "${ED}"/etc/mail/trusted-users
# trusted-users - users that can send mail as others without a warning
# apache, mailman, majordomo, uucp are good candidates
EOF
- cat <<- EOF > "${D}"/etc/mail/access
+ cat <<- EOF > "${ED}"/etc/mail/access
# Check the /usr/share/doc/sendmail/README.cf file for a description
# of the format of this file. (search for access_db in that file)
# The /usr/share/doc/sendmail/README.cf is part of the sendmail-doc
@@ -183,7 +186,7 @@ src_install() {
EOF
- cat <<- EOF > "${D}"/etc/conf.d/sendmail
+ cat <<- EOF > "${ED}"/etc/conf.d/sendmail
# Config file for /etc/init.d/sendmail
# add start-up options here
SENDMAIL_OPTS="-bd -q30m -L sm-mta" # default daemon mode
@@ -194,7 +197,7 @@ src_install() {
if use sasl; then
dodir /etc/sasl2
- cat <<- EOF > "${D}"/etc/sasl2/Sendmail.conf
+ cat <<- EOF > "${ED}"/etc/sasl2/Sendmail.conf
pwcheck_method: saslauthd
mech_list: PLAIN LOGIN