summaryrefslogtreecommitdiff
path: root/media-gfx/ansilove/ansilove-4.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/ansilove/ansilove-4.1.7.ebuild')
-rw-r--r--media-gfx/ansilove/ansilove-4.1.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/ansilove/ansilove-4.1.7.ebuild b/media-gfx/ansilove/ansilove-4.1.7.ebuild
new file mode 100644
index 000000000000..d0d4327ea128
--- /dev/null
+++ b/media-gfx/ansilove/ansilove-4.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
+HOMEPAGE="https://www.ansilove.org/
+ https://github.com/ansilove/ansilove/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="dev-libs/libansilove"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DENABLE_SECCOMP=NO
+ )
+ cmake_src_configure
+}