summaryrefslogtreecommitdiff
path: root/media-gfx/cura/cura-2.1.0_beta.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/cura/cura-2.1.0_beta.ebuild')
-rw-r--r--media-gfx/cura/cura-2.1.0_beta.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/media-gfx/cura/cura-2.1.0_beta.ebuild b/media-gfx/cura/cura-2.1.0_beta.ebuild
index 9a28b902e3e9..db1610abbb6f 100644
--- a/media-gfx/cura/cura-2.1.0_beta.ebuild
+++ b/media-gfx/cura/cura-2.1.0_beta.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
PYTHON_COMPAT=( python3_4 python3_5 )
-inherit cmake-utils fdo-mime gnome2-utils python-single-r1
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
MY_PN=Cura
MY_PV=${PV/_beta}
@@ -28,7 +29,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/${P}-fix-install-paths.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.0_beta-fix-install-paths.patch"
+)
+
DOCS=( README.md )
src_configure() {
@@ -52,13 +57,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}