summaryrefslogtreecommitdiff
path: root/media-gfx/cura/cura-2.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/cura/cura-2.3.1.ebuild')
-rw-r--r--media-gfx/cura/cura-2.3.1.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/media-gfx/cura/cura-2.3.1.ebuild b/media-gfx/cura/cura-2.3.1.ebuild
index 39b5a6d05144..9af78aaedc32 100644
--- a/media-gfx/cura/cura-2.3.1.ebuild
+++ b/media-gfx/cura/cura-2.3.1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
-PYTHON_COMPAT=( python3_4 python3_5 )
-inherit cmake-utils fdo-mime gnome2-utils python-single-r1
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
MY_PN=Cura
MY_PV=${PV/_beta}
@@ -29,7 +30,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=( "${FILESDIR}/${P}-fix-install-paths.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.1-fix-install-paths.patch"
+)
+
DOCS=( README.md )
src_configure() {
@@ -53,13 +58,13 @@ pkg_preinst() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
gnome2_icon_cache_update
}