summaryrefslogtreecommitdiff
path: root/media-gfx/darktable/darktable-3.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/darktable/darktable-3.2.1-r1.ebuild')
-rw-r--r--media-gfx/darktable/darktable-3.2.1-r1.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/media-gfx/darktable/darktable-3.2.1-r1.ebuild b/media-gfx/darktable/darktable-3.2.1-r1.ebuild
index adbe95a27f15..05d2a6634f26 100644
--- a/media-gfx/darktable/darktable-3.2.1-r1.ebuild
+++ b/media-gfx/darktable/darktable-3.2.1-r1.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit cmake flag-o-matic toolchain-funcs xdg
+LUA_COMPAT=( lua5-3 )
+
+inherit cmake flag-o-matic lua-single toolchain-funcs xdg
DOC_PV="3.0.0"
MY_PV="${PV/_/}"
@@ -16,12 +18,14 @@ SRC_URI="https://github.com/darktable-org/${PN}/releases/download/release-${MY_P
LICENSE="GPL-3 CC-BY-3.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64"
+KEYWORDS="amd64 ~arm64"
LANGS=" de es fr he it pl pt-BR ru sl"
IUSE="colord cups cpu_flags_x86_sse3 doc flickr geolocation gnome-keyring gphoto2 graphicsmagick jpeg2k kwallet
- lto lua nls opencl openmp openexr tools webp
+ lto lua nls opencl openmp openexr system-lua tools webp
${LANGS// / l10n_}"
+REQUIRED_USE="system-lua? ( lua ${LUA_REQUIRED_USE} )"
+
BDEPEND="
dev-util/intltool
virtual/pkgconfig
@@ -55,6 +59,7 @@ COMMON_DEPEND="
jpeg2k? ( media-libs/openjpeg:2= )
opencl? ( virtual/opencl )
openexr? ( media-libs/openexr:0= )
+ system-lua? ( ${LUA_DEPS} )
webp? ( media-libs/libwebp:0= )
"
DEPEND="${COMMON_DEPEND}
@@ -98,17 +103,21 @@ src_prepare() {
}
src_configure() {
- # TODO: switch to system Lua once 5.3 has been unmasked
+ # As of darktable-3.2.1, AVIF support is not compatible with >=media-libs/libavif-0.8.0; see Bug #751352.
+ # GMIC support mostly works but there are several problems with the media-gfx/gmic ebuilds currently
+ # in the tree, and the package itself has got no maintainer.
local mycmakeargs=(
- -DDONT_USE_INTERNAL_LUA=OFF
-DBUILD_CURVE_TOOLS=$(usex tools)
-DBUILD_NOISE_TOOLS=$(usex tools)
-DBUILD_PRINT=$(usex cups)
-DCUSTOM_CFLAGS=ON
+ -DDONT_USE_INTERNAL_LUA=$(usex system-lua)
-DRAWSPEED_ENABLE_LTO=$(usex lto)
+ -DUSE_AVIF=no
-DUSE_CAMERA_SUPPORT=$(usex gphoto2)
-DUSE_COLORD=$(usex colord)
-DUSE_FLICKR=$(usex flickr)
+ -DUSE_GMIC=no
-DUSE_GRAPHICSMAGICK=$(usex graphicsmagick)
-DUSE_KWALLET=$(usex kwallet)
-DUSE_LIBSECRET=$(usex gnome-keyring)