summaryrefslogtreecommitdiff
path: root/media-gfx/exiv2/exiv2-0.27.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/exiv2/exiv2-0.27.2.ebuild')
-rw-r--r--media-gfx/exiv2/exiv2-0.27.2.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-gfx/exiv2/exiv2-0.27.2.ebuild b/media-gfx/exiv2/exiv2-0.27.2.ebuild
index 3d6060c5535e..276e0c2eff31 100644
--- a/media-gfx/exiv2/exiv2-0.27.2.ebuild
+++ b/media-gfx/exiv2/exiv2-0.27.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,8 @@ else
KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
fi
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit cmake-multilib python-any-r1
DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
@@ -59,7 +60,7 @@ src_prepare() {
iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
mv -f doc/cmd.txt.tmp doc/cmd.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
}
@@ -79,11 +80,11 @@ multilib_src_configure() {
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if multilib_is_native_abi; then
use doc && eninja doc