summaryrefslogtreecommitdiff
path: root/media-gfx/gmic/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gmic/files')
-rw-r--r--media-gfx/gmic/files/gmic-3.1.6-ar_so.patch26
-rw-r--r--media-gfx/gmic/files/gmic-3.2.0-grep38.patch27
-rw-r--r--media-gfx/gmic/files/gmic-3.2.4-makefile_automagic.patch131
-rw-r--r--media-gfx/gmic/files/gmic-3.2.5-relative_rpath.patch22
-rw-r--r--media-gfx/gmic/files/gmic-3.2.6-makefile_target_deps.patch11
5 files changed, 0 insertions, 217 deletions
diff --git a/media-gfx/gmic/files/gmic-3.1.6-ar_so.patch b/media-gfx/gmic/files/gmic-3.1.6-ar_so.patch
deleted file mode 100644
index 007cdfb50de5..000000000000
--- a/media-gfx/gmic/files/gmic-3.1.6-ar_so.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -414,7 +414,6 @@
- _lib : libgmic.so use_libgmic
-
- libgmic.so: libgmic.o
-- ar rcs libgmic.a libgmic.o
- ifeq ($(OS),Darwin)
- $(CXX) -shared -std=c++11 -pedantic -o libgmic.so.$(VERSION) libgmic.o $(LIBS)
- else
-@@ -508,7 +507,6 @@
- @echo " done!"
-
- libcgmic.so: libcgmic.o
-- ar rcs libcgmic.a libcgmic.o
- ifeq ($(OS),Darwin)
- $(CXX) -shared -o libcgmic.so.$(VERSION) libcgmic.o libgmic.o $(LIBS)
- else
-@@ -558,7 +556,6 @@
- _libc_static: libcgmic_files libcgmic_static.so use_libcgmic_static
-
- libcgmic_static.so: libcgmic_static.o
-- ar rcs libcgmic_static.a libcgmic_static.o
- ifeq ($(OS),Darwin)
- $(CXX) -shared -static -o libcgmic_static.so.$(VERSION) libcgmic_static.o libgmic.o $(PIC) $(CFLAGS) $(LIBS)
- else
diff --git a/media-gfx/gmic/files/gmic-3.2.0-grep38.patch b/media-gfx/gmic/files/gmic-3.2.0-grep38.patch
deleted file mode 100644
index e25a809fdeea..000000000000
--- a/media-gfx/gmic/files/gmic-3.2.0-grep38.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Starting with version 3.8, grep no longer quietly ignores backslashes
-preceding a white-space character.
-
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -89,16 +89,16 @@
- WGET = wget --no-check-certificate --quiet -O
- PLUGINDIR = $(shell gimptool-2.0 --gimpplugindir)/plug-ins
- BASH_COMPLETIONSDIR = $(shell pkg-config --variable completionsdir bash-completion || echo $(PREFIX)/share/bash-completion/completions)
--VERSION = $(shell grep 'gmic_version\ ' gmic.h | tail -c4 | head -c3)
--VERSION1 = $(shell grep 'gmic_version\ ' gmic.h | tail -c4 | head -c1)
--VERSION2 = $(shell grep 'gmic_version\ ' gmic.h | tail -c3 | head -c1)
--VERSION3 = $(shell grep 'gmic_version\ ' gmic.h | tail -c2 | head -c1)
-+VERSION = $(shell grep 'gmic_version ' gmic.h | tail -c4 | head -c3)
-+VERSION1 = $(shell grep 'gmic_version ' gmic.h | tail -c4 | head -c1)
-+VERSION2 = $(shell grep 'gmic_version ' gmic.h | tail -c3 | head -c1)
-+VERSION3 = $(shell grep 'gmic_version ' gmic.h | tail -c2 | head -c1)
- SVERSION=$(VERSION1).$(VERSION2).$(VERSION3)
- SRC_PATH=$(shell pwd)
-
- # Check that versions of files 'CImg.h' and 'gmic.h' match.
- ifneq (,$(wildcard CImg.h))
--CIMG_VERSION = $(shell grep 'cimg_version\ ' CImg.h | tail -c4 | head -c3)
-+CIMG_VERSION = $(shell grep 'cimg_version ' CImg.h | tail -c4 | head -c3)
- else
- CIMG_VERSION = $(VERSION)
- endif
diff --git a/media-gfx/gmic/files/gmic-3.2.4-makefile_automagic.patch b/media-gfx/gmic/files/gmic-3.2.4-makefile_automagic.patch
deleted file mode 100644
index 965ba65ae624..000000000000
--- a/media-gfx/gmic/files/gmic-3.2.4-makefile_automagic.patch
+++ /dev/null
@@ -1,131 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -230,6 +230,7 @@
-
- # Enable parallelization in CImg, using OpenMP.
- # (http://www.openmp.org/)
-+ifeq ($(GMIC_USE_OPENMP),yes)
- ifdef IS_CLANG
- OPENMP_CFLAGS = -I/usr/lib/gcc/x86_64-linux-gnu/9/include -Dcimg_use_openmp -fopenmp=libomp
- OPENMP_LIBS =
-@@ -237,6 +238,7 @@
- OPENMP_CFLAGS = -fopenmp -Dcimg_use_openmp
- OPENMP_LIBS = -lgomp
- endif
-+endif
-
- # Enable software debugging.
- # (Use address sanitizer and thus slows down the code)
-@@ -258,9 +260,13 @@
- # Enable image display, using X11 (Unix).
- # (Keep /usr/ dirname here since X11 is located in /usr/ on Mac too)
- ifneq ($(OS),Darwin)
-+ifeq ($(GMIC_USE_X11),yes)
- X11_CFLAGS = -Dcimg_display=1 $(shell pkg-config --cflags x11 || echo -I/usr/X11R6/include) #-Dcimg_use_xrandr
- X11_LIBS = $(shell pkg-config --libs x11 || echo -L/usr/X11R6/lib -lX11) -lpthread # $(shell pkg-config --libs xrandr || echo -lXrandr)
- else
-+X11_CFLAGS = -Dcimg_display=0
-+endif
-+else
- ifeq (,$(wildcard /usr/X11))
- X11_CFLAGS = -Dcimg_display=0 #-Dcimg_use_xrandr
- X11_LIBS = -lpthread # $(shell pkg-config --libs xrandr || echo -lXrandr)
-@@ -272,8 +278,10 @@
-
- # Enable faster X11 display, using XShm extension.
- # (ftp://www.x.org/pub/X11R7.7/doc/man/man3/XShm.3.xhtml)
-+ifeq ($(GMIC_USE_XSHM),yes)
- XSHM_CFLAGS = -Dcimg_use_xshm $(shell pkg-config --cflags xcb-shm)
- XSHM_LIBS = $(shell pkg-config --libs xcb-shm || echo -L$(PREFIX)/X11R6/lib) -lXext
-+endif
-
- # Enable image display, using GDI32 (Windows).
- GDI32_CFLAGS = -Dcimg_display=2
-@@ -282,8 +290,10 @@
- # Enable native support of PNG image files, using the PNG library.
- # (http://www.libpng.org/pub/png/libpng.html)
- ifneq ($(OS),Darwin)
-+ifeq ($(GMIC_USE_PNG),yes)
- PNG_CFLAGS = -Dcimg_use_png $(shell pkg-config --cflags libpng)
- PNG_LIBS = $(shell pkg-config --libs libpng || echo -lpng -lz)
-+endif
- else
- ifeq (,$(wildcard /tmp/skl))
- PNG_CFLAGS = -Dcimg_use_png $(shell pkg-config --cflags libpng)
-@@ -296,54 +306,74 @@
-
- # Enable native support of JPEG image files, using the JPEG library.
- # (http://libjpeg.sourceforge.net/)
-+ifeq ($(GMIC_USE_JPEG),yes)
- JPEG_CFLAGS = -Dcimg_use_jpeg $(shell pkg-config --cflags libjpeg)
- JPEG_LIBS = $(shell pkg-config --libs libjpeg || echo -ljpeg)
-+endif
-
- # Enable native support of TIFF image files, using the TIFF library.
- # (http://www.libtiff.org/)
-+ifeq ($(GMIC_USE_TIFF),yes)
- TIFF_CFLAGS = -Dcimg_use_tiff $(shell pkg-config --cflags libtiff-4)
- TIFF_LIBS = $(shell pkg-config --libs libtiff-4 || echo -ltiff)
-+endif
-
- # Enable native support for loading HEIC/AVIF image files, using the libheif library.
- # ( https://github.com/strukturag/libheif )
-+ifeq ($(GMIC_USE_HEIF),yes)
- HEIF_CFLAGS = -Dcimg_use_heif
- HEIF_LIBS = -lheif
-+endif
-
- # Enable native support of MINC2 image files, using the MINC2 library.
- # ( http://en.wikibooks.org/wiki/MINC/Reference/MINC2.0_Users_Guide )
-+ifeq ($(GMIC_USE_MINC2),yes)
- MINC2_CFLAGS = -Dcimg_use_minc2 -I${HOME}/local/include
- MINC2_LIBS = -lminc_io -lvolume_io2 -lminc2 -lnetcdf -lhdf5 -lz -L${HOME}/local/lib
-+endif
-
- # Enable native support for downloading files from the network.
- # ( http://curl.haxx.se/libcurl/ )
-+ifeq ($(GMIC_USE_CURL),yes)
- CURL_CFLAGS = -Dcimg_use_curl $(shell pkg-config --cflags libcurl)
- CURL_LIBS = $(shell pkg-config --libs libcurl || echo -lcurl)
-+endif
-
- # Enable native support of webcams and video streaming, using the OpenCV library.
- # (https://opencv.org/)
-+ifeq ($(GMIC_USE_OPENCV),yes)
- OPENCV_CFLAGS = -Dcimg_use_opencv $(shell pkg-config opencv --cflags) -I/usr/include/opencv -I/usr/include/opencv4
- OPENCV_LIBS = $(shell pkg-config opencv --libs || echo -lopencv_core -lopencv_highgui -lopencv_videoio)
-+endif
-
- # Enable support of most classical image file formats, using the GraphicsMagick++ library.
- # (http://www.graphicsmagick.org/Magick++/)
-+ifeq ($(GMIC_USE_GRAPHICSMAGICK),yes)
- MAGICK_CFLAGS = -Dcimg_use_magick $(shell pkg-config --cflags GraphicsMagick++ || echo -I$(PREFIX)/$(INCLUDE)/GraphicsMagick)
- MAGICK_LIBS = $(shell pkg-config --libs GraphicsMagick++ || echo -lGraphicsMagick++)
-+endif
-
- # Enable native support of EXR image files, using the OpenEXR library.
- # (http://www.openexr.com/)
--OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(PREFIX)/$(INCLUDE)/OpenEXR)
--OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lIlmImf -lHalf)
-+ifeq ($(GMIC_USE_EXR),yes)
-+OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(USR)/$(INCLUDE)/OpenEXR -I$(USR)/$(INCLUDE)/Imath)
-+OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lOpenEXR -lImath)
-+endif
-
- # Enable Fast Fourier Transforms, using the FFTW3 library.
- # (http://www.fftw.org/)
-+ifeq ($(GMIC_USE_FFTW),yes)
- FFTW_CFLAGS = -Dcimg_use_fftw3 $(shell pkg-config --cflags fftw3)
- FFTW_LIBS = $(shell pkg-config --libs fftw3 || echo -lfftw3)
- FFTW_LIBS += -lfftw3_threads
-+endif
-
- # Enable native support of the BOARD library.
- # (https://github.com/c-koi/libboard)
-+ifeq ($(GMIC_USE_BOARD),yes)
- BOARD_CFLAGS = -Dcimg_use_board
- BOARD_LIBS = -lboard
-+endif
-
- GMIC_STD_CFLAGS = $(MANDATORY_CFLAGS) $(ABORT_CFLAGS) $(PARALLEL_CFLAGS) $(FFTW_CFLAGS) $(CURL_CFLAGS) $(PNG_CFLAGS) $(JPEG_CFLAGS) $(TIFF_CFLAGS)
- GMIC_STD_LIBS = $(MANDATORY_LIBS) $(PARALLEL_LIBS) $(FFTW_LIBS) $(CURL_LIBS) $(PNG_LIBS) $(JPEG_LIBS) $(TIFF_LIBS)
diff --git a/media-gfx/gmic/files/gmic-3.2.5-relative_rpath.patch b/media-gfx/gmic/files/gmic-3.2.5-relative_rpath.patch
deleted file mode 100644
index 113aa57c34c5..000000000000
--- a/media-gfx/gmic/files/gmic-3.2.5-relative_rpath.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -188,7 +188,7 @@
- ifndef NO_SRIPDLIB
- MANDATORY_CFLAGS += -std=c++11 -pedantic
- endif
--MANDATORY_LIBS += -L. -L$(PREFIX)/$(LIB) -Wl,-rpath,.
-+MANDATORY_LIBS += -L. -L$(PREFIX)/$(LIB)
- ifdef IS_GCC
- MANDATORY_CFLAGS += -Wall -Wextra -Wfatal-errors -Werror=unknown-pragmas -Werror=unused-label
- GCC_VER_GTEQ5 = $(shell expr `$(CXX) -dumpversion | cut -f1 -d.` \>= 5)
---- a/gmic-qt/gmic_qt.pro
-+++ b/gmic-qt/gmic_qt.pro
-@@ -434,7 +434,7 @@
-
- equals(GMIC_DYNAMIC_LINKING, "on" )|equals(GMIC_DYNAMIC_LINKING, "ON" ) {
- message(Dynamic linking with libgmic)
-- LIBS += -Wl,-rpath,. $$GMIC_PATH/libgmic.so
-+ LIBS += $$GMIC_PATH/libgmic.so
- }
-
- equals(GMIC_DYNAMIC_LINKING, "off" )|equals(GMIC_DYNAMIC_LINKING, "OFF" ) {
diff --git a/media-gfx/gmic/files/gmic-3.2.6-makefile_target_deps.patch b/media-gfx/gmic/files/gmic-3.2.6-makefile_target_deps.patch
deleted file mode 100644
index 6aea9e1579eb..000000000000
--- a/media-gfx/gmic/files/gmic-3.2.6-makefile_target_deps.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -503,7 +503,7 @@
- libcgmic.o: gmic_libc.cpp CImg.h gmic_libc.h gmic.h
- $(CXX) -o libcgmic.o -c gmic_libc.cpp -Dgmic_core $(PIC) $(CFLAGS)
-
--use_libcgmic: use_libcgmic.c gmic_libc.h
-+use_libcgmic: use_libcgmic.c libcgmic.so
- $(CC) -std=c99 -o use_libcgmic use_libcgmic.c -lcgmic $(LIBS)
-
- # libcgmic (static).