summaryrefslogtreecommitdiff
path: root/media-gfx/imagemagick/imagemagick-7.1.0.20-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/imagemagick/imagemagick-7.1.0.20-r1.ebuild')
-rw-r--r--media-gfx/imagemagick/imagemagick-7.1.0.20-r1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/media-gfx/imagemagick/imagemagick-7.1.0.20-r1.ebuild b/media-gfx/imagemagick/imagemagick-7.1.0.20-r1.ebuild
index ce2194dd3355..f860410a5f2d 100644
--- a/media-gfx/imagemagick/imagemagick-7.1.0.20-r1.ebuild
+++ b/media-gfx/imagemagick/imagemagick-7.1.0.20-r1.ebuild
@@ -13,7 +13,7 @@ else
MY_PV="$(ver_rs 3 '-')"
MY_P="ImageMagick-${MY_PV}"
SRC_URI="mirror://imagemagick/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="A collection of tools and libraries for many image formats"
@@ -85,6 +85,14 @@ PATCHES=(
S="${WORKDIR}/${MY_P}"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_prepare() {
default
eautoreconf
@@ -129,9 +137,6 @@ src_configure() {
use q8 && depth=8
use q32 && depth=32
- local openmp=disable
- use openmp && { tc-has-openmp && openmp=enable; }
-
use perl && perl_check_env
[[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
@@ -140,6 +145,7 @@ src_configure() {
$(use_enable static-libs static)
$(use_enable hdri)
$(use_enable opencl)
+ $(use_enable openmp)
--with-threads
--with-modules
--with-quantum-depth=${depth}
@@ -179,7 +185,6 @@ src_configure() {
$(use_with corefonts windows-font-dir "${EPREFIX}"/usr/share/fonts/corefonts)
$(use_with wmf)
$(use_with xml)
- --${openmp}-openmp
)
CONFIG_SHELL=$(type -P bash) econf "${myeconfargs[@]}"
}