summaryrefslogtreecommitdiff
path: root/media-gfx/mypaint
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/mypaint')
-rw-r--r--media-gfx/mypaint/Manifest1
-rw-r--r--media-gfx/mypaint/mypaint-1.2.1-r1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-gfx/mypaint/Manifest b/media-gfx/mypaint/Manifest
index 1d6392332fee..f09447431246 100644
--- a/media-gfx/mypaint/Manifest
+++ b/media-gfx/mypaint/Manifest
@@ -6,5 +6,6 @@ DIST mypaint-1.2.0.tar.xz 37895196 BLAKE2B fa0130a0b8ea6aba14f2994584f990c8c0cb4
DIST mypaint-1.2.1.tar.xz 37897196 BLAKE2B 2d8f6b03f710febae1c2d617a6e542543786be384585ae8a973604da2eba8a0fb770d185aa3d2dfc6f794adf29ffb9c217356a96ab27d677ebb57816f62fae9c SHA512 1783765e495b9535669a83a29d27ba684e6201fdfe0875bdd2c167b1dab8af05993b19025767fe0b2770ed9e578e4709f75d8a4820ac945812cba85609f9eb9b
EBUILD mypaint-1.1.0-r2.ebuild 1927 BLAKE2B e0d4354567a619e5d259fcb50820186fc8b6f4f6f7108c0676059da9a3065830b504b68a2f9e575032fb30e0b5b6e8e71de23d4e4f778cc28bb0d8e3220282ae SHA512 356a6bef73fb283b0e7953be068bdd8feec0d92a3e06a1fdf0fbe1d80fe6225a777cf95c6ae198afa40269bad9d25f8762c9ac318a8b2e4a3763912b40127477
EBUILD mypaint-1.2.0.ebuild 1738 BLAKE2B e81f01dd6cafee8337c2d6c7d967a02341d9ca4cab1fc8815b2eee71bcf186c32d6ebcc9655038e33f46018342a85be807dd05ba046c26932f67a4f332469ca8 SHA512 d00e0825a85be9e5129fd7895c9b08d91037a1c291d50a8bf2e425eca235d527386013092898061e173855af3c3c2c9c6ab93cef7c5309e028683bb7841217e4
+EBUILD mypaint-1.2.1-r1.ebuild 1742 BLAKE2B cddbca3b26a6f941fe684b05a9633aac0603f36a241701635d3fbb84a219ab357ed6346d047fa661450be64eaf48386e1f2eafe63e879028e63a5c08d8fa98ae SHA512 22c95f69ac1a55f986a969b5153db3d0c1d98479ef026f7ef902eeb6a249089c141674b38525a34b697306158cc4010a5d260e0229bb0ae855c9a8f7224f0d93
EBUILD mypaint-1.2.1.ebuild 1881 BLAKE2B 62c4152f2763737e6709fe5425aaab71c2bd69a3560c8acfab36997270d2e1690bb113ed15cbdaa464e8fed828249386cdb547621a1de7cc5e0c39318ab4379c SHA512 900af1c50c8d860b9e0551f7c12abe9ee3df5e21b900b78a92c17e7b9abf57968d6c1a895eb56869e9a45e2132bab40b3a9de6f49990f67577786904e8dccffd
MISC metadata.xml 247 BLAKE2B 3a8d267e6befd2f46c41982b7196470f32b4fcf5dc6a42ead10b13e81bdcb7975ea998a51d0deb2c3c1a49f00b5f9216d8e43ad7e6dd0aea0f3352b19532d0a0 SHA512 21b957bb801d29dfed1d0aeceac553c9ba039a7fe94ebf899e7ab5c3316bbad116c7bd63a07ccbbb8277d2ce19f27b964499d2ccd942028290519e465e989dbb
diff --git a/media-gfx/mypaint/mypaint-1.2.1-r1.ebuild b/media-gfx/mypaint/mypaint-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..8489c3857e41
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-1.2.1-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit fdo-mime gnome2-utils scons-utils toolchain-funcs python-single-r1
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.org/"
+SRC_URI="https://github.com/mypaint/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="cs de en_CA en_GB es fr hu id it ja ko nb nn_NO pl pt_BR ro ru sl sv uk zh_CN zh_TW"
+
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.4[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ >=dev-libs/json-c-0.11:=
+ media-libs/lcms:2
+ >=media-libs/libmypaint-1.3.0
+ media-libs/libpng:0=
+ gnome-base/librsvg
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ virtual/pkgconfig"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CC CXX
+ escons
+}
+
+src_install () {
+ escons prefix="${D}/usr" install
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm -rf "${ED}"/usr/share/locale/${x} || die
+ fi
+ done
+
+ python_optimize "${D}"usr/share/${PN}
+ # not used and broken
+ rm -r "${ED}"/usr/{include/,lib/libmypaint.a,lib/pkgconfig/} || die
+ # already provided by system-libmypaint
+ rm "${ED}"/usr/share/locale/*/LC_MESSAGES/libmypaint* || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}