summaryrefslogtreecommitdiff
path: root/media-gfx/shotwell
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest2
-rw-r--r--media-gfx/shotwell/shotwell-0.30.17.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 4188f4ca0b37..97d397d1ed35 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,4 +1,6 @@
AUX 0.30.16-optional-wayland.patch 2111 BLAKE2B 9d928c8b449792b198314c9f169dc2ddfddb97efbf43bf888a6e00fc47e9f60635f8d482a6b227335e0e7ef028e663b8b959a18658ba300ceb925704e977b8cb SHA512 4b6e00823a4cd271ba72b382b35694737d6944cbb123465da4243a16cb5cf6bbf3a8d3ecc707ded6e74df47ac76c5ebe1f789aebfc7c4a7b0ecd8e926d32c120
DIST shotwell-0.30.16.tar.xz 6532812 BLAKE2B caa2ff2f4536d8f04900d7ba7c583b7ec0d0244d6253bc17971e2b4e04aa3790b17e932b3367e1be40d4a0bb566bab31396aa5dfdb6dbb5c9803272cd7f94e97 SHA512 4ed725a34b1663b9cb63dcd13c98795fb2ea9a5d79ee4541276bc9dc2f607ce6466cc9c983bab55e7418e69eef3d1598846aeb6750f00927663756bd11d9a084
+DIST shotwell-0.30.17.tar.xz 6533460 BLAKE2B 58ec94f21bf465dcc19760f40235db7d2ad7d00c214802cd3ad6cfd67cb1088a5999f183c8ae36398e492a1b387e6ea717a9b8d0f31f4ef369e67c10150ae57a SHA512 f680b6f58538fb7b584594d00da7fe997dbc766583a5b5a85943b3df905dbc7192d3e7b5c7b47b6bd1221280995aaba878ea1afff9b042995bf30fbcbce5f7ea
EBUILD shotwell-0.30.16.ebuild 1947 BLAKE2B 2989733092e2ebdc07978fc2c0e4cf7a6228afd6e7e552e5e2e2552e9b2e0162543cbd168573f220ae488693a86f811d92a7b778872ed1f9e5c9d52f0911dfe7 SHA512 cd39afa12c9cd0329fbe4074a1a6f2380dbd7bd68bfc8695a18b7c43aaf72170582bedc8c6a1482e22fca2165c673ffebaf6d3caead0889f79dc67b4b36338eb
+EBUILD shotwell-0.30.17.ebuild 1922 BLAKE2B 8fdb19955cbddde52faaa29a2bd2440b460c2750ff687904cf8a922739d9beffe0fd6064add2e07d32531b9ebaf0e284e0fd8670e64e8e69b3e0418a15d54b54 SHA512 144a38af74dc67a54862d6c86536329a2ef3b48a6de8e314612bcede5ab03bd96c338ad75ef36196d61a52066d09e2403aafd7ff0d9cbc082e5085630f73728b
MISC metadata.xml 685 BLAKE2B 60a7448a9542a8663c25966bfa7dae2bbd50fb727795300e6483ea39147521b2d6ebd3c4dd894c553cbd94df18f4e39e1d88359d9da346a02cb7a02709d19f11 SHA512 da9730037e4d473898cfa537446b9ea3dae77bb915c54df139738a4e19b824ff273c36c2e3a43f421d91e2de09789843ccc84bd4cb4bcda258eee37fd9dec425
diff --git a/media-gfx/shotwell/shotwell-0.30.17.ebuild b/media-gfx/shotwell/shotwell-0.30.17.ebuild
new file mode 100644
index 000000000000..850f6a2458ae
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.30.17.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev wayland"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3[wayland?]
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8
+ >=net-libs/webkit-gtk-2.26:4
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.10.4
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16:=
+ dev-libs/libgdata
+ >=app-crypt/gcr-3:=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-2.3.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:2.4[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr[vala]
+"
+
+PATCHES=( "${FILESDIR}"/0.30.16-optional-wayland.patch )
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity-support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ -Dextra-plugins=true
+ #trace
+ #measure
+ -Ddupe-detection=true
+ $(meson_use udev)
+ -Dinstall-apport-hook=false
+ $(meson_use opencv face-detection)
+ -Dfatal_warnings=false
+ $(meson_use wayland)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}