summaryrefslogtreecommitdiff
path: root/media-gfx/synnefo
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/synnefo')
-rw-r--r--media-gfx/synnefo/Manifest3
-rw-r--r--media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch99
-rw-r--r--media-gfx/synnefo/synnefo-1.1.0.ebuild4
3 files changed, 104 insertions, 2 deletions
diff --git a/media-gfx/synnefo/Manifest b/media-gfx/synnefo/Manifest
index 57f90510a2e9..94cf4215ed2a 100644
--- a/media-gfx/synnefo/Manifest
+++ b/media-gfx/synnefo/Manifest
@@ -1,3 +1,4 @@
+AUX synnefo-1.1.0-cxx11.patch 5387 BLAKE2B 64280de77601f7a44e03138fa7af59c8e5466621e8f3735babf830c4b0a917e5c6b1147de6f7078cbc503d2a71755e11143d4e8993502ba6bc23bb40edc6cbbb SHA512 7c9e99ddf56758caaca004e33707372f1df7ad21269cefa59c04a3e1f733408abb83ae7e60f13499e8a185cfc7b8b1dfe62a506863fd289f78b1e71fa311ea6c
DIST synnefo-1.1.0.tar.gz 161822 BLAKE2B 1d1981ae815e692cd9230690214bff039c2b523f78faab34d35ad8f25cefbc656ace2ba2ca240baa7d305417f17ea0c4d0cad5d300a638b15cc81d315fdf474c SHA512 f4c50e6e018b0dcf91715c379cd5b79452886fb7fda189ad47a22b9d5f47b3ca710b959b773a1e0a42564e881d09da088a88eef505719b1b1fbfbb5e21fb26ef
-EBUILD synnefo-1.1.0.ebuild 712 BLAKE2B 6be06777f5b9f0a89c8fd86e0910a95b0e8dde9bfa3f41579d2120809afe40b61dbfe0e5bd34a6607deec6ce5ffdff8067774bd50c6ecd0b52eec86713efc3d6 SHA512 4df0ac04e02437afcfd04065dd5942bfafc8d83187a8e4f989166bdb566bf1e98602b645f40433a8214ba7eebe48c3e492d84fab1344943a8a8694167adbbecd
+EBUILD synnefo-1.1.0.ebuild 769 BLAKE2B 3bea272c73df737d3f4ed0b6fdd89d68c265c1afdd858f206c51406d5dea219a6668ca966ee19467ca0757bf919f163857ef5921d4fd90e94cabe19e6061c8af SHA512 80bf16de85f329ce9e4602b864331e08ff74d53729d4a85ce114ba5757da1e7e5184ed5a3eee7d9cac10e790947f15a6e591f5a812e4cb6b2017e79c19edd471
MISC metadata.xml 333 BLAKE2B ae4c40964873b751ece7a62f6f8c4cbc7d6d6cb9d4008e958a243f8a6c5ba3461156a5032097997b3d90a5b9dde516bd5351f4e7cde27f83cbaf82224c7ee1d0 SHA512 49d4f64a95ddf7b75f0e3efe44bc03e8df9f565aec70c52838dea32badc5809d0b3945f87a4de3bc6704f0a3e1732e683412d4ffd480e5ef40bf763c958b7936
diff --git a/media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch b/media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch
new file mode 100644
index 000000000000..fdc438f09d26
--- /dev/null
+++ b/media-gfx/synnefo/files/synnefo-1.1.0-cxx11.patch
@@ -0,0 +1,99 @@
+From 30691bdb98566482e1c29ee440cfc8531fac2616 Mon Sep 17 00:00:00 2001
+From: Kai-Uwe Behrmann <ku.b@gmx.de>
+Date: Thu, 22 Dec 2016 13:02:05 +0100
+Subject: [PATCH] fix some compiler warnings about string macro usage
+
+---
+ src/modules/devices/sy_devices.cpp | 12 ++++++------
+ src/modules/information/sy_info.cpp | 4 ++--
+ src/modules/settings/sy_settings.cpp | 2 +-
+ 3 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/src/modules/devices/sy_devices.cpp b/src/modules/devices/sy_devices.cpp
+index b477fd7..f60c4a2 100644
+--- a/src/modules/devices/sy_devices.cpp
++++ b/src/modules/devices/sy_devices.cpp
+@@ -146,10 +146,10 @@ int syDeviceGetProfile( oyConfig_s * device, uint32_t icc_profile_flags, oyProfi
+ {
+ oyOptions_s * options = 0;
+ oyOptions_SetFromText( &options,
+- "//"OY_TYPE_STD"/config/command",
++ "//" OY_TYPE_STD "/config/command",
+ "list", OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+- "//"OY_TYPE_STD"/config/icc_profile.x_color_region_target",
++ "//" OY_TYPE_STD "/config/icc_profile.x_color_region_target",
+ "yes", OY_CREATE_NEW );
+ oyOptions_SetFromInt( &options, "///icc_profile_flags", icc_profile_flags, 0, OY_CREATE_NEW );
+ int error = oyDeviceAskProfile2( device, options, profile );
+@@ -595,7 +595,7 @@ int SyDevicesModule::installTaxiProfile(oyConfig_s * device)
+ "//" OY_TYPE_STD "/icc_profile_flags",
+ icc_profile_flags, 0, OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+-+ "//"OY_TYPE_STD"/config/skip_ask_for_profile",
+++ "//" OY_TYPE_STD "/config/skip_ask_for_profile",
+ "yes", OY_CREATE_NEW );
+ error = oyDeviceSetup(device, options);
+ oyOptions_Release( &options );
+@@ -803,7 +803,7 @@ void SyDevicesModule::populateDeviceListing()
+ char ** texts = 0;
+
+ // get all configuration filters
+- oyConfigDomainList( "//"OY_TYPE_STD"/device/config.icc_profile",
++ oyConfigDomainList( "//" OY_TYPE_STD "/device/config.icc_profile",
+ &texts, &count, &rank_list ,0 );
+
+ for (i = 0; i < count; i++)
+@@ -960,7 +960,7 @@ oyConfig_s * SyDevicesModule::getCurrentDevice( void )
+ oyOptions_SetFromText( &options, "//" OY_TYPE_STD "/config/command",
+ "properties", OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+- "//"OY_TYPE_STD"/config/icc_profile.x_color_region_target",
++ "//" OY_TYPE_STD "/config/icc_profile.x_color_region_target",
+ "yes", OY_CREATE_NEW );
+ if(current_device_class && current_device_name)
+ error = oyDeviceGet( OY_TYPE_STD, current_device_class, current_device_name,
+@@ -1003,7 +1003,7 @@ void SyDevicesModule::assignProfile( QString profile_name, oySCOPE_e scope )
+ "//" OY_TYPE_STD "/icc_profile_flags",
+ icc_profile_flags, 0, OY_CREATE_NEW );
+ oyOptions_SetFromText( &options,
+-+ "//"OY_TYPE_STD"/config/skip_ask_for_profile",
+++ "//" OY_TYPE_STD "/config/skip_ask_for_profile",
+ "yes", OY_CREATE_NEW );
+ oyDeviceSetup( device, options ); /* reinitialise */
+ oyOptions_Release( &options );
+diff --git a/src/modules/information/sy_info.cpp b/src/modules/information/sy_info.cpp
+index 9d194cf..3b4909c 100644
+--- a/src/modules/information/sy_info.cpp
++++ b/src/modules/information/sy_info.cpp
+@@ -231,7 +231,7 @@ void SyInfoModule::populateDeviceProfiles( QTreeWidgetItem * deviceListTree )
+ oyConfDomain_s * d = 0;
+
+ // get all configuration filters
+- oyConfigDomainList( "//"OY_TYPE_STD"/device/config.icc_profile",
++ oyConfigDomainList( "//" OY_TYPE_STD "/device/config.icc_profile",
+ &texts, &count, &rank_list ,0 );
+
+ for(i = count - 1; i >= 0; --i)
+@@ -266,7 +266,7 @@ void SyInfoModule::populateDeviceProfiles( QTreeWidgetItem * deviceListTree )
+ oyConfig_s * device = oyConfigs_Get( devices, j );
+ char * device_info = 0;
+ oyOptions_s * options = 0;
+- oyOptions_SetFromText( &options, "//"OY_TYPE_STD"/config/icc_profile.x_color_region_target",
++ oyOptions_SetFromText( &options, "//" OY_TYPE_STD "/config/icc_profile.x_color_region_target",
+ "yes", OY_CREATE_NEW );
+ oyOptions_SetFromInt( &options, "///icc_profile_flags", icc_profile_flags, 0, OY_CREATE_NEW );
+
+diff --git a/src/modules/settings/sy_settings.cpp b/src/modules/settings/sy_settings.cpp
+index a1c54ee..3f74c1d 100644
+--- a/src/modules/settings/sy_settings.cpp
++++ b/src/modules/settings/sy_settings.cpp
+@@ -213,7 +213,7 @@ void SySendNativeUpdate(const char * func)
+ {
+ // e.g. send native (e.g. X11) reload event
+ oyOptions_s * opts = oyOptions_New(NULL), * results = 0;
+- int error = oyOptions_Handle( "//"OY_TYPE_STD"/send_native_update_event",
++ int error = oyOptions_Handle( "//" OY_TYPE_STD "/send_native_update_event",
+ opts,"send_native_update_event",
+ &results );
+ oyOptions_Release( &opts );
diff --git a/media-gfx/synnefo/synnefo-1.1.0.ebuild b/media-gfx/synnefo/synnefo-1.1.0.ebuild
index eb126309b0bc..3ac8c9b7578d 100644
--- a/media-gfx/synnefo/synnefo-1.1.0.ebuild
+++ b/media-gfx/synnefo/synnefo-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,3 +31,5 @@ RDEPEND="${DEPEND}
"
DOCS=( AUTHORS.md README.md )
+
+PATCHES=( "${FILESDIR}/${P}-cxx11.patch" ) # bug 739982