summaryrefslogtreecommitdiff
path: root/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild')
-rw-r--r--media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild b/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild
new file mode 100644
index 000000000000..0474ba4b3c29
--- /dev/null
+++ b/media-gfx/vkBasalt/vkBasalt-0.3.2.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="A Vulkan post-processing layer for Linux"
+HOMEPAGE="https://github.com/DadSchoorse/vkBasalt"
+SRC_URI="https://github.com/DadSchoorse/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+BDEPEND="dev-util/glslang
+ virtual/pkgconfig"